summary refs log tree commit diff
path: root/gnu/packages/gnome.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2021-07-26 07:35:39 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2021-07-26 09:47:22 +0200
commite8563962ee996311795d8377feb08e9156acbffc (patch)
tree5a4c0634f8d38341556f2e996fed00e4c75f6aa6 /gnu/packages/gnome.scm
parent781a2befeeeaf5bc97d118705a15b29ce47050b3 (diff)
downloadguix-e8563962ee996311795d8377feb08e9156acbffc.tar.gz
gnu: Remove libgnomeprint.
* gnu/packages/gnome.scm (libgnomeprint): Remove unused variable.
Diffstat (limited to 'gnu/packages/gnome.scm')
-rw-r--r--gnu/packages/gnome.scm31
1 files changed, 0 insertions, 31 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 27188787dc..6feef9662c 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -3973,37 +3973,6 @@ graphical interfaces described in glade files and for accessing the
 widgets built in the loading process.")
     (license license:gpl2+))) ; This is correct.  GPL not LGPL
 
-(define-public libgnomeprint
-  ;; This library has been deprecated since 2006; see
-  ;; <https://mail.gnome.org/archives/devel-announce-list/2006-August/msg00005.html>.
-  (package
-    (name "libgnomeprint")
-    (version "2.18.8")
-    (source (origin
-              (method url-fetch)
-              (uri (string-append "mirror://gnome/sources/" name "/"
-                                  (version-major+minor version)  "/"
-                                  name "-" version ".tar.bz2"))
-              (sha256
-               (base32
-                "14cnimvlc7ky22g2snyf4362412k3jk1syjf8b9887q5a63fqd0h"))))
-    (build-system gnu-build-system)
-    (inputs
-     `(("popt" ,popt)
-       ("libart-lgpl" ,libart-lgpl)
-       ("gtk+" ,gtk+-2)
-       ("libxml2" ,libxml2)))
-    (native-inputs
-     `(("intltool" ,intltool)
-       ("glib" ,glib "bin")             ; for glib-genmarshal, etc.
-       ("pkg-config" ,pkg-config)))
-    (home-page "https://projects.gnome.org/gnome-print/home/faq.html")
-    (synopsis "Printing framework for GNOME")
-    (description
-     "GNOME-print was a printing framework for GNOME.  It has been deprecated
-since ca. 2006, when GTK+ itself incorporated printing support.")
-    (license license:lgpl2.0+)))
-
 
 (define-public libgnomeprintui
   ;; Deprecated; see libgnomeprint.