summary refs log tree commit diff
path: root/gnu/packages/gnome.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2021-12-02 13:42:31 +0100
committerLudovic Courtès <ludo@gnu.org>2021-12-02 14:59:57 +0100
commite080e35dc1f012fa57a8e77759f933abdc3b8fc2 (patch)
tree76087a5f53b096d83c14a7861794f42287e870e1 /gnu/packages/gnome.scm
parent689d141cd83f56ee82b54bdaaef5c6d57a980a91 (diff)
downloadguix-e080e35dc1f012fa57a8e77759f933abdc3b8fc2.tar.gz
gnu: glade: Remove dependency on GJS on non-x86_64.
* gnu/packages/gnome.scm (glade3)[arguments]: Add optional
'skip-gjs-test' phase.
[native-inputs]: Provide GJS only when 'target-x86-64?'.
Diffstat (limited to 'gnu/packages/gnome.scm')
-rw-r--r--gnu/packages/gnome.scm20
1 files changed, 19 insertions, 1 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 727d0617ec..bada1e866b 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -3292,6 +3292,18 @@ API add-ons to make GTK+ widgets OpenGL-capable.")
            (lambda _
              (substitute* "meson_post_install.py"
                (("gtk-update-icon-cache") "true"))))
+
+         ,@(if (this-package-native-input "gjs")
+               '()
+               '((add-after 'unpack 'skip-gjs-test
+                   (lambda _
+                     ;; When the optional dependency on GJS is missing, skip
+                     ;; the GJS plugin tests.
+                     (substitute* "tests/modules.c"
+                       (("g_test_add.*JavaScript.*" all)
+                        (string-append "// " all "\n")))
+                     (delete-file "tests/catalogs/gjsplugin.xml")))))
+
          (add-before 'configure 'fix-docbook
            (lambda* (#:key inputs #:allow-other-keys)
              (substitute* "man/meson.build"
@@ -3320,7 +3332,13 @@ current/manpages/docbook.xsl")
        ("glib:bin" ,glib "bin")
        ("python-pygobject" ,python-pygobject)
        ("gobject-introspection" ,gobject-introspection)
-       ("gjs" ,gjs)
+
+       ;; GJS depends on Rust, which is x86_64-only so far, so remove the GJS
+       ;; dependency on other platforms (FIXME).
+       ,@(if (target-x86-64?)
+             `(("gjs" ,gjs))
+             '())
+
        ("pkg-config" ,pkg-config)
        ("xorg-server" ,xorg-server-for-tests)))
     (home-page "https://glade.gnome.org")