summary refs log tree commit diff
path: root/gnu/packages/gnome.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2019-04-01 01:14:35 +0200
committerMarius Bakke <mbakke@fastmail.com>2019-04-01 01:32:39 +0200
commitc1124207cbcd18fee936bef29ef86218b9d81cee (patch)
tree17eb934eda05a40c55148c6164ba75f2af14fece /gnu/packages/gnome.scm
parent3eed550072d6f71eff20de269d313fc1dfe3e332 (diff)
downloadguix-c1124207cbcd18fee936bef29ef86218b9d81cee.tar.gz
gnu: evolution-data-server: Remove obsolete phase.
This is a fixup for the merge of da43d1c ("gnu: evolution-data-server: Add
'libedataserverui' output.") and bb10e7c ("gnu: evolution-data-server: Update
to 3.28.3.") in 571fb00.

* gnu/packages/gnome.scm (evolution-data-server)[arguments]: Remove phase that
is no longer needed since version 3.28.2.
Diffstat (limited to 'gnu/packages/gnome.scm')
-rw-r--r--gnu/packages/gnome.scm12
1 files changed, 0 insertions, 12 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 0fa8141fdd..c54cd65ff2 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -5159,18 +5159,6 @@ Exchange, Last.fm, IMAP/SMTP, Jabber, SIP and Kerberos.")
                ;; Remove it so the configure flag is respected.
                (("SET\\(CMAKE_INSTALL_RPATH .*") ""))
              #t))
-         (add-before 'configure 'factor-webkit
-           (lambda _
-             (substitute* "CMakeLists.txt"
-               (("webkit2gtk-4\\.0>=\\$[{]webkit2gtk_minimum_version[}]") "")
-               (("if[(]ENABLE_OAUTH2[)]")
-                (string-append
-                 "if(ENABLE_OAUTH2)\n"
-                 "\tpkg_check_modules(OAUTH2_UI REQUIRED "
-                 "webkit2gtk-4.0>=${webkit2gtk_minimum_version})")))
-             (substitute* "src/libedataserverui/CMakeLists.txt"
-               (("\\$[{]OAUTH2_([A-Z_]+)[}]" all part)
-                (string-append all " ${OAUTH2_UI_" part "}")))))
          (add-after 'install 'split
            (lambda* (#:key outputs #:allow-other-keys)
              (let ((out (assoc-ref outputs "out"))