summary refs log tree commit diff
path: root/gnu/packages/gnome.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-04-20 15:50:08 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-04-21 00:44:03 -0400
commit56f382141d5c6c68d5e5a13cad67a1bf50eb73d2 (patch)
treec4734335181eadabc9f53e74c311ea4f23a0004b /gnu/packages/gnome.scm
parenteef131d7ae3aeeb8d7144eeb2fa3b3c5afc26c37 (diff)
downloadguix-56f382141d5c6c68d5e5a13cad67a1bf50eb73d2.tar.gz
gnu: seed: Remove patch-docbook-xml phase.
* gnu/packages/gnome.scm (seed) [arguments]: Remove patch-docbook-xml
phase.  Use gexps.
[native-inputs, inputs, propagated-inputs]: Remove labels.
Diffstat (limited to 'gnu/packages/gnome.scm')
-rw-r--r--gnu/packages/gnome.scm99
1 files changed, 43 insertions, 56 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 6b4a4f0fbc..e9a78ce90c 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -480,65 +480,52 @@ bindings.")
     (build-system glib-or-gtk-build-system)
     (outputs '("out" "doc"))
     (arguments
-     `(#:configure-flags
-       (list
-        "--disable-static"
-        "--enable-xorg-module"
-        (string-append "--with-html-dir="
-                       (assoc-ref %outputs "doc")
-                       "/share/gtk-doc/html")
-        "--with-webkit=4.0")
-       #:phases
-       (modify-phases %standard-phases
-         ;; The seed-webkit.patch patches configure.ac.
-         ;; So the source files need to be re-bootstrapped.
-         (add-after 'unpack 'trigger-bootstrap
-           (lambda _
-             (for-each delete-file
-                       (list
-                        "configure"
-                        "Makefile.in"))
-             #t))
-         (add-after 'unpack 'patch-tests
-           (lambda* (#:key outputs #:allow-other-keys)
-             (substitute* (find-files "." "\\.js$")
-              (("#!/usr/bin/env seed")
-               (string-append "#!" (getcwd) "/src/seed")))
-             #t))
-         (add-before 'build 'patch-docbook-xml
-           (lambda* (#:key inputs #:allow-other-keys)
-             (with-directory-excursion "doc"
-               (substitute* '("reference/seed-docs.sgml" "modules/book.xml")
-                 (("http://www.oasis-open.org/docbook/xml/4.1.2/")
-                  (string-append (assoc-ref inputs "docbook-xml")
-                                 "/xml/dtd/docbook/"))))
-             #t)))))
+     (list #:configure-flags
+           #~(list "--disable-static"
+                   "--enable-xorg-module"
+                   (string-append "--with-html-dir=" #$output:doc
+                                  "/share/gtk-doc/html")
+                   "--with-webkit=4.0")
+           #:phases
+           #~(modify-phases %standard-phases
+               ;; The seed-webkit.patch patches configure.ac.
+               ;; So the source files need to be re-bootstrapped.
+               (add-after 'unpack 'trigger-bootstrap
+                 (lambda _
+                   (for-each delete-file
+                             (list "configure"
+                                   "Makefile.in"))))
+               (add-after 'unpack 'patch-tests
+                 (lambda* (#:key outputs #:allow-other-keys)
+                   (substitute* (find-files "." "\\.js$")
+                     (("#!/usr/bin/env seed")
+                      (string-append "#!" (getcwd) "/src/seed"))))))))
     (native-inputs
-     `(("autoconf" ,autoconf)
-       ("automake" ,automake)
-       ("docbook-xml" ,docbook-xml-4.1.2)
-       ("gettext" ,gettext-minimal)
-       ("gobject-introspection" ,gobject-introspection)
-       ("gtk-doc" ,gtk-doc/stable)
-       ("intltool" ,intltool)
-       ("libtool" ,libtool)
-       ("pkg-config" ,pkg-config)))
+     (list autoconf
+           automake
+           docbook-xml-4.1.2
+           gettext-minimal
+           gobject-introspection
+           gtk-doc/stable
+           intltool
+           libtool
+           pkg-config))
     (inputs
-     `(("cairo" ,cairo)
-       ("dbus" ,dbus)
-       ("dbus-glib" ,dbus-glib)
-       ("gnome-js-common" ,gnome-js-common)
-       ("gtk+" ,gtk+)
-       ("gtk+-2" ,gtk+-2)
-       ("libffi" ,libffi)
-       ("libxml2" ,libxml2)
-       ("mpfr" ,mpfr)
-       ("readline" ,readline)
-       ("sqlite" ,sqlite)
-       ("xscrnsaver" ,libxscrnsaver)))
+     (list cairo
+           dbus
+           dbus-glib
+           gnome-js-common
+           gtk+
+           gtk+-2
+           libffi
+           libxml2
+           mpfr
+           readline
+           sqlite
+           libxscrnsaver))
     (propagated-inputs
-     `(("glib" ,glib)
-       ("webkit" ,webkitgtk-with-libsoup2)))
+     (list glib
+           webkitgtk-with-libsoup2))
     (synopsis "GObject JavaScriptCore bridge")
     (description "Seed is a library and interpreter, dynamically bridging
 (through GObjectIntrospection) the WebKit JavaScriptCore engine, with the