summary refs log tree commit diff
path: root/gnu/packages/gnome.scm
diff options
context:
space:
mode:
authorLiliana Marie Prikler <liliana.prikler@gmail.com>2022-10-01 17:53:25 +0200
committerLiliana Marie Prikler <liliana.prikler@gmail.com>2022-10-01 18:10:01 +0200
commit46e1eb48c97a51d4d92b92f8606d8106427fb55c (patch)
tree4b2359e461916ca024cf20721e01a9cf04b5a65a /gnu/packages/gnome.scm
parent7f0ff905386be612307a198ca98efda50d1362ff (diff)
downloadguix-46e1eb48c97a51d4d92b92f8606d8106427fb55c.tar.gz
gnu: komikku: Use G-Expressions.
* gnu/packages/gnome.scm (komikku)[arguments]: Convert to list of G-Expressions.
Diffstat (limited to 'gnu/packages/gnome.scm')
-rw-r--r--gnu/packages/gnome.scm39
1 files changed, 20 insertions, 19 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index d8b3692b80..81b8c241ee 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -13023,25 +13023,26 @@ profiler via Sysprof, debugging support, and more.")
          "17r059srxrx26w40swy47pdpyigyjdczp8550g4rfh86qs3ld4il"))))
     (build-system meson-build-system)
     (arguments
-     `(#:glib-or-gtk? #t
-       #:phases
-       (modify-phases %standard-phases
-         (add-after 'unpack 'patch-sources
-           (lambda _
-             (substitute* "komikku/utils.py"
-               (("from komikku\\.servers import get_servers_list")
-                ;; code following that line should migrate old databases
-                ;; but the line itself results in an import error
-                "return data_dir_path"))))
-         (add-after 'unpack 'skip-gtk-update-icon-cache
-           (lambda _
-             (substitute* "meson_post_install.py"
-               (("gtk-update-icon-cache") (which "true")))))
-         (add-after 'glib-or-gtk-wrap 'python-and-gi-wrap
-           (lambda* (#:key outputs #:allow-other-keys)
-             (wrap-program (search-input-file outputs "bin/komikku")
-               `("GUIX_PYTHONPATH" = (,(getenv "GUIX_PYTHONPATH")))
-               `("GI_TYPELIB_PATH" = (,(getenv "GI_TYPELIB_PATH")))))))))
+     (list
+      #:glib-or-gtk? #t
+      #:phases
+      #~(modify-phases %standard-phases
+          (add-after 'unpack 'patch-sources
+            (lambda _
+              (substitute* "komikku/utils.py"
+                (("from komikku\\.servers import get_servers_list")
+                 ;; code following that line should migrate old databases
+                 ;; but the line itself results in an import error
+                 "return data_dir_path"))))
+          (add-after 'unpack 'skip-gtk-update-icon-cache
+            (lambda _
+              (substitute* "meson_post_install.py"
+                (("gtk-update-icon-cache") (which "true")))))
+          (add-after 'glib-or-gtk-wrap 'python-and-gi-wrap
+            (lambda* (#:key outputs #:allow-other-keys)
+              (wrap-program (search-input-file outputs "bin/komikku")
+                `("GUIX_PYTHONPATH" = (,(getenv "GUIX_PYTHONPATH")))
+                `("GI_TYPELIB_PATH" = (,(getenv "GI_TYPELIB_PATH")))))))))
     (inputs
      (list bash-minimal
            gtk+