summary refs log tree commit diff
path: root/gnu/packages/gnome.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2018-05-01 09:50:57 -0500
committerLudovic Courtès <ludo@gnu.org>2018-05-05 22:52:26 +0200
commit312afa7d563302da41ca7be862c7ce2e00acc7b5 (patch)
treea92356d65b9d5b2e1290b2d5659a6d5b095e7583 /gnu/packages/gnome.scm
parentbd7a147ee4933c73e02a987ca5d7fc464d77d3b3 (diff)
downloadguix-312afa7d563302da41ca7be862c7ce2e00acc7b5.tar.gz
gnu: Add GHex.
* gnu/packages/gnome.scm (ghex): New variable.

Co-authored-by: Jovany Leandro G.C <bit4bit@riseup.net>.
Diffstat (limited to 'gnu/packages/gnome.scm')
-rw-r--r--gnu/packages/gnome.scm29
1 files changed, 29 insertions, 0 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index b8beda3656..b5bde0bd4d 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -7259,3 +7259,32 @@ prevention of repetitive strain injury (RSI).  The program frequently alerts
 you to take micro-pauses, rest breaks and restricts you to your daily limit")
       (home-page "http://www.workrave.org")
       (license license:gpl3+))))
+
+(define-public ghex
+  (package
+    (name "ghex")
+    (version "3.18.3")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append "mirror://gnome/sources/" name "/"
+                                  (version-major+minor version) "/"
+                                  name "-" version ".tar.xz"))
+              (sha256
+               (base32
+                "1lq8920ad2chi9ibmyq0x9hg9yk63b0kdbzid03w42cwdzw50x66"))))
+    (build-system glib-or-gtk-build-system)
+    (native-inputs
+     `(("pkg-config" ,pkg-config)
+       ("gnome-common" ,gnome-common)
+       ("which" ,which)
+       ("intltool" ,intltool)
+       ("yelp-tools" ,yelp-tools)
+       ("desktop-file-utils" ,desktop-file-utils))) ;for 'desktop-file-validate'
+    (inputs
+     `(("atk" ,atk)
+       ("gtk" ,gtk+)))
+    (synopsis "GNOME hexadecimal editor")
+    (description "The GHex program can view and edit files in two ways:
+hexadecimal or ASCII.  It is useful for editing binary files in general.")
+    (home-page "https://wiki.gnome.org/Apps/Ghex")
+    (license license:gpl2)))