summary refs log tree commit diff
path: root/gnu/packages/gnome.scm
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2017-04-24 01:03:34 -0400
committerLeo Famulari <leo@famulari.name>2017-04-24 01:10:23 -0400
commit43acfcb2c77fd9d8b08e3e4366248bdc20c998e9 (patch)
treee2040e002bc0cbed1e84eb0faf11e219c80049d4 /gnu/packages/gnome.scm
parent638787307e30c96aa3864a4b6d822da06fca6688 (diff)
downloadguix-43acfcb2c77fd9d8b08e3e4366248bdc20c998e9.tar.gz
libcroco: Fix CVE-2017-{7960,7961}.
* gnu/packages/gnome.scm (libcroco)[replacement]: New field.
(libcroco/fixed): New variable.
* gnu/packages/patches/libcroco-CVE-2017-7960.patch,
gnu/packages/patches/libcroco-CVE-2017-7961.patch: New files.
* gnu/local.mk (dist_patch_DATA): Add them.
Diffstat (limited to 'gnu/packages/gnome.scm')
-rw-r--r--gnu/packages/gnome.scm14
1 files changed, 14 insertions, 0 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 96dcbda72e..fc19318b91 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -945,6 +945,7 @@ the GNOME desktop environment.")
 (define-public libcroco
   (package
     (name "libcroco")
+    (replacement libcroco/fixed)
     (version "0.6.11")
     (source (origin
               (method url-fetch)
@@ -972,6 +973,19 @@ XML/CSS rendering engine.")
     ;; LGPLv2.1-only.
     (license license:lgpl2.1)))
 
+(define libcroco/fixed
+  (package
+    (inherit libcroco)
+    (replacement #f)
+    (source
+      (origin
+        (inherit (package-source libcroco))
+        (patches
+          (append
+            (origin-patches (package-source libcroco))
+            (search-patches "libcroco-CVE-2017-7960.patch"
+                            "libcroco-CVE-2017-7961.patch")))))))
+
 (define-public libgsf
   (package
     (name "libgsf")