summary refs log tree commit diff
path: root/gnu/packages/gnome.scm
diff options
context:
space:
mode:
authorTimothy Sample <samplet@ngyro.com>2017-10-23 21:36:15 -0400
committerLudovic Courtès <ludo@gnu.org>2017-11-07 18:09:13 +0100
commit51bc8357e8457d5d7168d8837da6e14fa2d98485 (patch)
tree0306575000acabb74939b573066baea0e44d5efe /gnu/packages/gnome.scm
parent950d8e5d8ca5971c93082a9bdc4415fa20568e21 (diff)
downloadguix-51bc8357e8457d5d7168d8837da6e14fa2d98485.tar.gz
gnu: gdm: Add configure flags for better defaults.
* gnu/packages/gnome.scm (gdm)[arguments]<#:configure-flags>: Add
--with-initial-vt=7 and --enable-gdm-xsession.

Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/gnome.scm')
-rw-r--r--gnu/packages/gnome.scm10
1 files changed, 10 insertions, 0 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 35c40f233c..1584943ac2 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -5218,6 +5218,16 @@ libxml2.")
      '(#:configure-flags
        `("--without-plymouth"
          "--disable-systemd-journal"
+
+         ;; Using --with-initial-vt=7 allows GDM to run alongside TTY 1,
+         ;; instead of having to replace it (i.e., stopping the mingetty
+         ;; service for TTY 1 before starting GDM).
+         "--with-initial-vt=7"
+
+         ;; By default, GDM expects distributions to install a custom Xsession
+         ;; script. It provides a generic one if --enable-gdm-xsession is set.
+         "--enable-gdm-xsession"
+
          "--localstatedir=/var"
          ,(string-append "--with-default-path="
                          (string-join '("/run/setuid-programs"