summary refs log tree commit diff
path: root/gnu/packages/gnome.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-01-18 10:47:08 -0500
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-01-18 10:47:44 -0500
commit1995920f687020720d22bf8656fdde5ea1908747 (patch)
tree96f07e44527abff23e16f1f352610144190516ee /gnu/packages/gnome.scm
parent719deaa8813e33261c3da6f407c5ef109e5f5e92 (diff)
downloadguix-1995920f687020720d22bf8656fdde5ea1908747.tar.gz
gnu: folks: Add python to native inputs.
Reported by ekaitz on #guix.

* gnu/packages/gnome.scm (folks): Delete trailing #t.
[native-inputs]: Use new style.  Add python.
Diffstat (limited to 'gnu/packages/gnome.scm')
-rw-r--r--gnu/packages/gnome.scm16
1 files changed, 8 insertions, 8 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index be1b8a3e59..59fd7fa3dc 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -9992,8 +9992,7 @@ functionality and behavior.")
            ;; Don't create 'icon-theme.cache'.
            (lambda _
              (substitute* "meson_post_install.py"
-               (("gtk-update-icon-cache") "true"))
-             #t)))))
+               (("gtk-update-icon-cache") "true")))))))
     (inputs
      (list bdb
            dbus-glib
@@ -10003,12 +10002,13 @@ functionality and behavior.")
            readline
            telepathy-glib))
     (native-inputs
-     `(("glib:bin" ,glib "bin")
-       ("gobject-introspection" ,gobject-introspection)
-       ("python-dbusmock" ,python-dbusmock)
-       ("intltool" ,intltool)
-       ("pkg-config" ,pkg-config)
-       ("vala" ,vala)))
+     (list `(,glib "bin")
+           gobject-introspection
+           python-dbusmock
+           intltool
+           pkg-config
+           python
+           vala))
     (synopsis "Library to aggregate data about people")
     (description "Libfolks is a library that aggregates information about people
 from multiple sources (e.g., Telepathy connection managers for IM contacts,