summary refs log tree commit diff
path: root/gnu/packages/gnome.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2018-12-30 19:35:46 +0200
committerEfraim Flashner <efraim@flashner.co.il>2018-12-30 20:22:59 +0200
commit684f97f8c903b1133658943c7f6c0e1eb4f1b3de (patch)
treededdc0b04c4858e5663819b1b89e04ee13473159 /gnu/packages/gnome.scm
parentbbbe7adda68b120b1461d30c3106f4976ddc6a72 (diff)
downloadguix-684f97f8c903b1133658943c7f6c0e1eb4f1b3de.tar.gz
gnu: vinagre: Update package for newer freerdp.
* gnu/packages/gnome.scm (vinagre)[source]: Update patches.
[arguments]: Add custom  phase to replace 'freerdp' with
'freerdp2'. Remove configure flags.
* gnu/packages/patches/vinagre-revert-1.patch,
gnu/packages/patches/vinagre-revert-2.patch: Remove files.
* gnu/packages/patches/vinagre-newer-freerdp.patch,
gnu/packages/patches/vinagre-newer-rdp-parameters.patch: New files.
* gnu/local.mk (dist_patch_DATA): Register changes.
Diffstat (limited to 'gnu/packages/gnome.scm')
-rw-r--r--gnu/packages/gnome.scm15
1 files changed, 10 insertions, 5 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 5fec15b5d5..2331b33f71 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -2221,13 +2221,20 @@ selection and URL hints.")))
               (uri (string-append "mirror://gnome/sources/" name "/"
                                   (version-major+minor version) "/"
                                   name "-" version ".tar.xz"))
-              (patches ; We have to revert 2 commits to build against freerdp 1.1.
-               (search-patches "vinagre-revert-1.patch"
-                               "vinagre-revert-2.patch"))
+              (patches (search-patches "vinagre-newer-freerdp.patch"
+                                       "vinagre-newer-rdp-parameters.patch"))
               (sha256
                (base32
                 "10jya3jyrm18nbw3v410gbkc7677bqamax44pzgd3j15randn76d"))))
     (build-system glib-or-gtk-build-system)
+    (arguments
+     '(#:phases
+       (modify-phases %standard-phases
+         (add-after 'unpack 'patch-configure
+           (lambda _
+             (substitute* "configure"
+               (("freerdp") "freerdp2"))
+             #t)))))
     (native-inputs
      `(("pkg-config" ,pkg-config)
        ("intltool" ,intltool)
@@ -2244,8 +2251,6 @@ selection and URL hints.")))
        ("spice-gtk" ,spice-gtk)
        ("telepathy-glib" ,telepathy-glib)
        ("vte" ,vte)))
-    (arguments
-     `(#:configure-flags '("--enable-rdp")))
     (home-page "https://wiki.gnome.org/Apps/Vinagre")
     (synopsis "Remote desktop viewer for GNOME")
     (description "Vinagre is a remote display client supporting the VNC, SPICE