summary refs log tree commit diff
path: root/gnu/packages/gnome.scm
diff options
context:
space:
mode:
author宋文武 <iyzsong@gmail.com>2015-12-15 19:43:33 +0800
committer宋文武 <iyzsong@gmail.com>2015-12-20 18:59:21 +0800
commit8e1dd04f450aeef8ebdf7e3030ea3961f3beba75 (patch)
tree42a3c7a2b6282b743ec29143d0bfccac6785046a /gnu/packages/gnome.scm
parente68232797656813ceb139fa01d465290eed84a66 (diff)
downloadguix-8e1dd04f450aeef8ebdf7e3030ea3961f3beba75.tar.gz
gnu: Add libgtop.
* gnu/packages/gnome.scm (libgtop): New variable.
Diffstat (limited to 'gnu/packages/gnome.scm')
-rw-r--r--gnu/packages/gnome.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 59e43dcc96..d45a240532 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -4335,3 +4335,30 @@ libxml2.")
      "GNOME Display Manager is a system service that is responsible for
 providing graphical log-ins and managing local and remote displays.")
     (license license:gpl2+)))
+
+(define-public libgtop
+  (package
+    (name "libgtop")
+    (version "2.32.0")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append "mirror://gnome/sources/" name "/"
+                                  (version-major+minor version) "/"
+                                  name "-" version ".tar.xz"))
+              (sha256
+               (base32
+                "13hpml2vfm23816qggr5fvxj75ndb1dq4rgmi7ik6azj69ij8hw4"))))
+    (build-system gnu-build-system)
+    (native-inputs
+     `(("gobject-introspection" ,gobject-introspection)
+       ("intltool" ,intltool)
+       ("perl" ,perl)
+       ("pkg-config" ,pkg-config)))
+    (propagated-inputs
+     `(("glib" ,glib))) ; required by libgtop-2.0.pc
+    (synopsis "Portable system access library")
+    (home-page "https://www.gnome.org/")
+    (description
+     "LibGTop is a library to get system specific data such as CPU and memory
+usage and information about running processes.")
+    (license license:gpl2+)))