summary refs log tree commit diff
path: root/gnu/packages/gnome.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2016-01-14 11:03:49 +0100
committerRicardo Wurmus <rekado@elephly.net>2016-01-15 22:29:37 +0100
commitf5ca44b86e26bcfc8c32c5d21b3ba76185148294 (patch)
tree5474ed685c1441b61a40c3955d4a8c1cf38b9813 /gnu/packages/gnome.scm
parent45f2ffb48cf58fcec9ba43b742921cab678303ba (diff)
downloadguix-f5ca44b86e26bcfc8c32c5d21b3ba76185148294.tar.gz
gnu: glade: Update to 3.18.5.
* gnu/packages/gnome.scm (glade): Update to 3.18.5.
[arguments]: Disable tests; add "fix-docbook" phase.
[inputs]: Replace "gtk+-2" with "gtk+".
[native-inputs]: Add "itstool", "libxslt", "docbook-xml", "docbook-xsl";
replace "python" with "python-2".
Diffstat (limited to 'gnu/packages/gnome.scm')
-rw-r--r--gnu/packages/gnome.scm27
1 files changed, 22 insertions, 5 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index e88ee8d904..9ce750ddef 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -751,22 +751,39 @@ API add-ons to make GTK+ widgets OpenGL-capable.")
 (define-public glade3
   (package
     (name "glade")
-    (version "3.8.5")
+    (version "3.18.3")
     (source (origin
               (method url-fetch)
               (uri (string-append "mirror://gnome/sources/" name "/"
                                   (version-major+minor version)  "/"
-                                  name "3-" version ".tar.xz"))
+                                  name "-" version ".tar.xz"))
               (sha256
                (base32
-                "0d97df5pfkrh5670a98r3d3w8zlbh1jcax6cvq6j6a20vzjgd9aq"))))
+                "0lk4nvd5s8px9i0pbq7bncikgn2lpx7vjh787d3cvzpvwx3cxnzc"))))
     (build-system gnu-build-system)
+    (arguments
+     `(#:tests? #f ; needs X, GL, and software rendering
+       #:phases
+       (modify-phases %standard-phases
+         (add-before 'configure 'fix-docbook
+           (lambda* (#:key inputs #:allow-other-keys)
+             (substitute* "man/Makefile.in"
+               (("http://docbook.sourceforge.net/release/xsl/current/manpages/docbook.xsl")
+                (string-append (assoc-ref inputs "docbook-xsl")
+                               "/xml/xsl/docbook-xsl-"
+                               ,(package-version docbook-xsl)
+                               "/manpages/docbook.xsl")))
+             #t)))))
     (inputs
-     `(("gtk+" ,gtk+-2)
+     `(("gtk+" ,gtk+)
        ("libxml2" ,libxml2)))
     (native-inputs
      `(("intltool" ,intltool)
-       ("python" ,python)
+       ("itstool" ,itstool)
+       ("libxslt" ,libxslt) ;for xsltproc
+       ("docbook-xml" ,docbook-xml-4.2)
+       ("docbook-xsl" ,docbook-xsl)
+       ("python" ,python-2)
        ("pkg-config" ,pkg-config)))
     (home-page "https://glade.gnome.org")
     (synopsis "GTK+ rapid application development tool")