summary refs log tree commit diff
path: root/gnu/packages/gnome.scm
diff options
context:
space:
mode:
authorKei Kebreau <kkebreau@posteo.net>2019-07-22 17:55:35 -0400
committerKei Kebreau <kkebreau@posteo.net>2019-12-07 14:04:11 -0500
commit995ef5ea11a9003abc0ea90b4ce61e53ef1eb679 (patch)
treecef5a2c2dd9902cc021e4cc19ebb8bdb46aea128 /gnu/packages/gnome.scm
parent06323c8ed749b6e65c77e8e82382a2acba7df6ab (diff)
downloadguix-995ef5ea11a9003abc0ea90b4ce61e53ef1eb679.tar.gz
gnu: totem: Update to 3.32.1.
* gnu/packages/gnome.scm (totem): Update to 3.32.1.
[source]: Remove patches.
[arguments]: Add 'pre-check' phase.  Remove #:parallel-build?.
[native-inputs]: Add python-pylint and xorg-server-for-tests.
[inputs]: Replace python2-pygobject with python-pygobject.
* gnu/packages/patches/totem-meson-easy-codec.patch,
gnu/packages/patches/totem-meson-compat.patch: Delete files.
* gnu/local.mk (dist_patch_DATA): Adjust accordingly.
Diffstat (limited to 'gnu/packages/gnome.scm')
-rw-r--r--gnu/packages/gnome.scm27
1 files changed, 13 insertions, 14 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index b0d98e3c9b..8ff04ada86 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -4139,7 +4139,7 @@ for application developers.")
 (define-public totem
   (package
     (name "totem")
-    (version "3.30.0")
+    (version "3.32.1")
     (source
      (origin
        (method url-fetch)
@@ -4148,9 +4148,7 @@ for application developers.")
                            name "-" version ".tar.xz"))
        (sha256
         (base32
-         "0rahkybxbmxhlmrrgrzxny1xm7wycx7ib4blxp1i2l1q3i8s84b0"))
-       (patches (search-patches "totem-meson-easy-codec.patch"
-                                "totem-meson-compat.patch"))))
+         "0yra8apc7smpwf7d1k8crhrm8d4wix24ds6i9yxbch1v11jnhr3v"))))
     (build-system meson-build-system)
     (native-inputs
      `(("pkg-config" ,pkg-config)
@@ -4159,7 +4157,9 @@ for application developers.")
        ("glib:bin" ,glib "bin")                   ;for 'glib-mkenums'
        ("intltool" ,intltool)
        ("itstool" ,itstool)
-       ("xmllint" ,libxml2)))
+       ("xmllint" ,libxml2)
+       ("python-pylint" ,python-pylint)
+       ("xorg-server" ,xorg-server-for-tests)))
     (propagated-inputs
      `(("dconf" ,dconf)))
     (inputs
@@ -4187,8 +4187,7 @@ for application developers.")
        ("gsettings-desktop-schemas" ,gsettings-desktop-schemas)
        ("adwaita-icon-theme" ,adwaita-icon-theme)
        ("python" ,python)
-       ("python-pygobject" ,python2-pygobject)
-       ;; XXX TODO pylint needed for python support
+       ("python-pygobject" ,python-pygobject)
        ("totem-pl-parser" ,totem-pl-parser)
        ("grilo" ,grilo)
        ("grilo-plugins" ,grilo-plugins)
@@ -4196,12 +4195,6 @@ for application developers.")
     (arguments
      `(#:glib-or-gtk? #t
 
-       ;; Disable parallel builds until
-       ;; https://debbugs.gnu.org/cgi/bugreport.cgi?bug=28813 is
-       ;; fixed.  Try enabling it when updating this package in case
-       ;; upstream has fixed it.
-       #:parallel-build? #f
-
        ;; Disable automatic GStreamer plugin installation via PackageKit and
        ;; all that.
        #:configure-flags '("-D" "enable-easy-codec-installation=no"
@@ -4209,7 +4202,6 @@ for application developers.")
                            ;; Do not build .a files for the plugins, it's
                            ;; completely useless.  This saves 2 MiB.
                            "--default-library" "shared")
-
        #:phases
        (modify-phases %standard-phases
          (add-after 'unpack 'skip-gtk-update-icon-cache
@@ -4223,6 +4215,13 @@ for application developers.")
           (lambda _
             (setenv "DESTDIR" "/")
             #t))
+         (add-before
+          'check 'pre-check
+          (lambda _
+            ;; Tests require a running X server.
+            (system "Xvfb :1 &")
+            (setenv "DISPLAY" ":1")
+            #t))
          (add-after
           'install 'wrap-totem
           (lambda* (#:key inputs outputs #:allow-other-keys)