summary refs log tree commit diff
path: root/gnu/packages/gnome.scm
diff options
context:
space:
mode:
authorKei Kebreau <kkebreau@posteo.net>2019-07-29 14:02:18 -0400
committerKei Kebreau <kkebreau@posteo.net>2019-12-07 14:04:14 -0500
commitc1e419c4f47733f2cec1463350e795ae6264c113 (patch)
tree1ab8fe0d2703c123614aa77da39ee899beadf7a4 /gnu/packages/gnome.scm
parent3748992a9e50bfa4e4d90f147302c3d4cb3c3990 (diff)
downloadguix-c1e419c4f47733f2cec1463350e795ae6264c113.tar.gz
gnu: gnome-klotski: Update to 3.32.0.
* gnu/packages/gnome.scm (gnome-klotski): Update to 3.32.0.
[build-system]: Use meson-build-system.
[arguments]: Set glib-or-gtk? flag and add 'skip-gtk-update-icon-cache' phase.
[native-inputs]: Add glib:bin and vala.
Diffstat (limited to 'gnu/packages/gnome.scm')
-rw-r--r--gnu/packages/gnome.scm18
1 files changed, 15 insertions, 3 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 3f9085ce0d..1bf309a3ed 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -4048,7 +4048,7 @@ GNOME Games, but it may be used by others.")
 (define-public gnome-klotski
   (package
     (name "gnome-klotski")
-    (version "3.22.3")
+    (version "3.32.0")
     (source (origin
               (method url-fetch)
               (uri (string-append "mirror://gnome/sources/" name "/"
@@ -4056,13 +4056,25 @@ GNOME Games, but it may be used by others.")
                                   name "-" version ".tar.xz"))
               (sha256
                (base32
-                "0prc0s28pdflgzyvk1g0yfx982q2grivmz3858nwpqmbkha81r7f"))))
-    (build-system glib-or-gtk-build-system)
+                "1p4s15gxj6gasix22z9vlx2yrx196fvcxr6v6qrl569idfgjbi72"))))
+    (build-system meson-build-system)
+    (arguments
+     '(#:glib-or-gtk? #t
+       #:phases
+       (modify-phases %standard-phases
+         (add-after 'unpack 'skip-gtk-update-icon-cache
+           ;; Don't create 'icon-theme.cache'.
+           (lambda _
+             (substitute* "build-aux/meson_post_install.py"
+               (("gtk-update-icon-cache") (which "true")))
+             #t)))))
     (native-inputs
      `(("desktop-file-utils" ,desktop-file-utils)
+       ("glib:bin" ,glib "bin") ; for glib-compile-resources
        ("intltool" ,intltool)
        ("itstool" ,itstool)
        ("pkg-config" ,pkg-config)
+       ("vala" ,vala)
        ("xmllint" ,libxml2)))
     (inputs
      `(("gtk+" ,gtk+)