summary refs log tree commit diff
path: root/gnu/packages/gnome.scm
diff options
context:
space:
mode:
authorKei Kebreau <kkebreau@posteo.net>2019-12-17 11:01:23 -0500
committerKei Kebreau <kkebreau@posteo.net>2020-04-18 16:49:54 -0400
commit162048be3b838e221e5256b0f670ac6f884f607a (patch)
tree3772f17d095214674af202425245ade2c81b3dfc /gnu/packages/gnome.scm
parent462d3416a871f97ae3de867e725f8c6e4f976731 (diff)
downloadguix-162048be3b838e221e5256b0f670ac6f884f607a.tar.gz
gnu: evolution-data-server: Update to 3.34.2.
* gnu/packages/gnome.scm (evolution-data-server): Update to 3.34.2.
[arguments]: Adjust 'disable-failing-tests' phase.
* gnu/packages/patches/evolution-data-server-libical-compat.patch: Update patch.

(cherry picked from commit 3febbdc80004c907507dbf4162bf6e7bfde74d28)
Diffstat (limited to 'gnu/packages/gnome.scm')
-rw-r--r--gnu/packages/gnome.scm11
1 files changed, 2 insertions, 9 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 02b89ee539..8754c08b3c 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -6155,7 +6155,7 @@ Exchange, Last.fm, IMAP/SMTP, Jabber, SIP and Kerberos.")
 (define-public evolution-data-server
   (package
     (name "evolution-data-server")
-    (version "3.32.4")
+    (version "3.34.2")
     (source (origin
               (method url-fetch)
               (uri (string-append "mirror://gnome/sources/" name "/"
@@ -6165,7 +6165,7 @@ Exchange, Last.fm, IMAP/SMTP, Jabber, SIP and Kerberos.")
                                        "evolution-data-server-libical-compat.patch"))
               (sha256
                (base32
-                "0zsc9xwy6ixk3x0dx69ax5isrdw8qxjdxg2i5fr95s40nss7rxl3"))))
+                "16z85y6hhazcrp5ngw47w4x9r0j8zrj7awv5im58hhp0xs19zf1y"))))
     (build-system cmake-build-system)
     (arguments
      '(#:configure-flags
@@ -6192,13 +6192,6 @@ Exchange, Last.fm, IMAP/SMTP, Jabber, SIP and Kerberos.")
              (delete-file-recursively "tests/book-migration")
              (substitute* "tests/CMakeLists.txt"
                (("add_subdirectory\\(book-migration\\)") ""))
-             ;; tests/libebook/client/test-book-client-view-operations:8077):
-             ;; e-data-server-WARNING **:
-             ;; (src/libedataserver/e-source-registry.c:264):thread_closure_free:
-             ;; runtime check failed:
-             ;; (!g_main_context_pending (closure->main_context))
-             (substitute* "tests/libebook/client/CMakeLists.txt"
-               (("test-book-client-view-operations") ""))
              #t))
          (add-after 'unpack 'patch-paths
           (lambda _