summary refs log tree commit diff
path: root/gnu/packages/gnome.scm
diff options
context:
space:
mode:
author宋文武 <iyzsong@gmail.com>2015-10-17 10:48:52 +0800
committer宋文武 <iyzsong@gmail.com>2015-10-17 10:48:52 +0800
commitf4925a4fb89c745fadbe9867ac5e017215d97acf (patch)
treed25481893a860742667cf609a0ba206edb7c81e2 /gnu/packages/gnome.scm
parent5f37e56ba41edb1bd47b7b1663aea07078f943d2 (diff)
downloadguix-f4925a4fb89c745fadbe9867ac5e017215d97acf.tar.gz
gnu: vala: Update to 0.30.0.
* gnu/packages/gnome.scm (vala): Update to 0.30.0.
  [arguments]: Run tests with "DBUS_FATAL_WARNINGS=0'.
Diffstat (limited to 'gnu/packages/gnome.scm')
-rw-r--r--gnu/packages/gnome.scm8
1 files changed, 5 insertions, 3 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 5811299d35..dc41e9eb94 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -1627,7 +1627,7 @@ passwords in the GNOME keyring.")
 (define-public vala
   (package
     (name "vala")
-    (version "0.28.0")
+    (version "0.30.0")
     (source (origin
               (method url-fetch)
               (uri (string-append "mirror://gnome/sources/" name "/"
@@ -1635,14 +1635,16 @@ passwords in the GNOME keyring.")
                                   name "-" version ".tar.xz"))
               (sha256
                (base32
-                "0zwpzhkhfk3piya14m7p2hl2vaabahprphppfm46ci91z39kp7hd"))))
+                "1pyyhfw3zzbhxfscbn8xz70dg6vx0kh8gshzikpxczhg01xk7w31"))))
     (build-system gnu-build-system)
     (arguments
      '(#:phases
        (modify-phases %standard-phases
-         (add-before 'check 'set-cc
+         (add-before 'check 'pre-check
                      (lambda _
                        (setenv "CC" "gcc")
+                       ;; For missing '/etc/machine-id'.
+                       (setenv "DBUS_FATAL_WARNINGS" "0")
                        #t)))))
     (native-inputs
      `(("pkg-config" ,pkg-config)