summary refs log tree commit diff
path: root/gnu/packages/gnome.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2020-02-16 09:06:53 +0200
committerEfraim Flashner <efraim@flashner.co.il>2020-02-16 09:19:06 +0200
commit778d6b522ae361767d3cf984a3b182bac7361b7a (patch)
treef613550262043334df156b37f3598dc7e2d7d618 /gnu/packages/gnome.scm
parent481a0f1a7ceac666a011b28324220584ead07698 (diff)
downloadguix-778d6b522ae361767d3cf984a3b182bac7361b7a.tar.gz
gnu: Remove obsolete bootstrap workaround phases.
* gnu/packages/admin.scm (igt-gpu-tools)[arguments]: Don't set
NOCONFIGURE environment variable.
* gnu/packages/algebra.scm (givaro, fflas-ffpack, linbox),
* gnu/packages/arcan.scm (xarcan),
* gnu/packages/audio.scm (rtmidi),
* gnu/packages/cinnamon.scm (cinnamon-desktop),
* gnu/packages/gnome.scm (dia, libxklavier, byzanz),
* gnu/packages/image-viewers.scm (geeqie),
* gnu/packages/libusb.scm (libplist),
* gnu/packages/mail.scm (libetpan),
* gnu/packages/networking.scm (aircrack-ng),
* gnu/packages/terminals.scm (tilda, kmscon),
* gnu/packages/xorg.scm (xf86-video-intel, xcompmgr) [arguments]: Same.
Diffstat (limited to 'gnu/packages/gnome.scm')
-rw-r--r--gnu/packages/gnome.scm23
1 files changed, 3 insertions, 20 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index cc00b69cf3..d9a5e6fe5b 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -911,13 +911,6 @@ useful as a tutorial and users' guide for new or less experienced users.")
          ("perl" ,perl)
          ("pkg-config" ,pkg-config)
          ("python-wrapper" ,python-wrapper)))
-      (arguments
-       `(#:phases
-         (modify-phases %standard-phases
-           (add-before 'bootstrap 'dont-configure-during-bootstrap
-             (lambda _
-               (setenv "NOCONFIGURE" "true")
-               #t)))))
       (home-page "https://wiki.gnome.org/Apps/Dia")
       (synopsis "Diagram creation for GNOME")
       (description "Dia can be used to draw different types of diagrams, and
@@ -3505,13 +3498,7 @@ and objects.")
               (file-name (git-file-name name version))))
     (build-system gnu-build-system)
     (arguments
-     '(#:phases
-       (modify-phases %standard-phases
-         (add-after 'unpack 'no-configure
-           (lambda* _
-            (setenv "NOCONFIGURE" "1")
-            #t)))
-       #:configure-flags
+     '(#:configure-flags
        (list (string-append "--with-xkb-base="
                             (assoc-ref %build-inputs "xkeyboard-config")
                             "/share/X11/xkb")
@@ -7924,7 +7911,7 @@ documents and diagrams, playing media, scanning, and much more.")
       (arguments
        '(#:phases
          (modify-phases %standard-phases
-           (replace 'bootstrap
+           (add-before 'bootstrap 'build-without-Werror
              (lambda _
                ;; The build system cleverly detects that we're not building from
                ;; a release tarball and turns on -Werror for GCC.
@@ -7932,11 +7919,7 @@ documents and diagrams, playing media, scanning, and much more.")
                ;; causes the build to fail unnecessarily, so we remove the flag.
                (substitute* '("configure.ac")
                  (("-Werror") ""))
-               ;; The autogen.sh script in gnome-common will run ./configure
-               ;; by default, which is problematic because source shebangs
-               ;; have not yet been patched.
-               (setenv "NOCONFIGURE" "t")
-               (zero? (system* "sh" "autogen.sh")))))))
+               #t)))))
       (native-inputs
        `(("autoconf" ,autoconf)
          ("automake" ,automake)