summary refs log tree commit diff
path: root/gnu/packages/gnome.scm
diff options
context:
space:
mode:
authorKei Kebreau <kei@openmailbox.org>2017-06-30 17:36:35 -0400
committerKei Kebreau <kei@openmailbox.org>2017-07-03 09:52:59 -0400
commit85c774808fc13a0adc603784b2358a7c285c4822 (patch)
tree1187b47df665cc10cbb9a4144665df48e637fbe0 /gnu/packages/gnome.scm
parent4f80be730ef648bd50c2d54ebca5e1fd6c8d8855 (diff)
downloadguix-85c774808fc13a0adc603784b2358a7c285c4822.tar.gz
gnu: gcr: Enable working tests.
* gnu/packages/patches/gcr-disable-failing-tests.patch,
gnu/packages/patches/gcr-fix-collection-tests-to-work-with-gpg-21.patch:
New files.
* gnu/local.mk (dist_patch_DATA): Add patches.
* gnu/packages/gnome.scm (gcr)[source]: Use patches.
[arguments]: Enable tests.
Diffstat (limited to 'gnu/packages/gnome.scm')
-rw-r--r--gnu/packages/gnome.scm9
1 files changed, 5 insertions, 4 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index e6072e033a..3491f4be1c 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -470,12 +470,13 @@ and keep up to date translations of documentation.")
                                  name "-" version ".tar.xz"))
              (sha256
               (base32
-               "0ydk9dzxx6snxza7j5ps8x932hbr3x1b8hhcaqjq4w4admi2qmwh"))))
+               "0ydk9dzxx6snxza7j5ps8x932hbr3x1b8hhcaqjq4w4admi2qmwh"))
+             (patches
+              (search-patches "gcr-disable-failing-tests.patch"
+                              "gcr-fix-collection-tests-to-work-with-gpg-21.patch"))))
     (build-system gnu-build-system)
     (arguments
-     '(#:tests? #f ;25 of 598 tests fail because /var/lib/dbus/machine-id does
-                   ;not exist
-       #:phases (modify-phases %standard-phases
+     '(#:phases (modify-phases %standard-phases
                   (add-before
                    'check 'pre-check
                    (lambda* (#:key inputs #:allow-other-keys)