summary refs log tree commit diff
path: root/gnu/packages/gnome.scm
diff options
context:
space:
mode:
authorRaghav Gururajan <raghavgururajan@disroot.org>2020-08-08 23:32:47 -0400
committerDanny Milosavljevic <dannym@scratchpost.org>2020-08-19 19:04:01 +0200
commit948143a32f4f5a8574712938c20f6c99c46b29cc (patch)
treea67ab6f209eb23043213491405a9c2d5535cfb94 /gnu/packages/gnome.scm
parent7b0777d182f08b07d7f5a91bbade484a90503072 (diff)
downloadguix-948143a32f4f5a8574712938c20f6c99c46b29cc.tar.gz
gnu: sushi: Update package definition.
* gnu/packages/gnome.scm (sushi) [version]: Update to 3.34.0.
[source]<origin>[sha256]: Modify base32.
[arguments]<#:phases>['wrap-typelib]: Modify phase.
[inputs]: Add glib and gtk+. Replace gdk-pixbuf with gdk-pixbuf+svg.
Remove clutter, clutter-gst, clutter-gtk, libxml2 and neon.
[synopsis]: Modify.

Signed-off-by: Danny Milosavljevic <dannym@scratchpost.org>
Diffstat (limited to 'gnu/packages/gnome.scm')
-rw-r--r--gnu/packages/gnome.scm47
1 files changed, 23 insertions, 24 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 961f744062..1cf2386bc7 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -1693,55 +1693,54 @@ masses.")
 (define-public sushi
   (package
     (name "sushi")
-    (version "3.32.1")
-    (source (origin
-              (method url-fetch)
-              (uri (string-append "mirror://gnome/sources/" name "/"
-                                  (version-major+minor version) "/"
-                                  name "-" version ".tar.xz"))
-              (sha256
-               (base32
-                "02idvqjk76lii9xyg3b1yz4rw721709bdm5j8ikjym6amcghl0aj"))))
+    (version "3.34.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri
+        (string-append "mirror://gnome/sources/" name "/"
+                       (version-major+minor version) "/"
+                       name "-" version ".tar.xz"))
+       (sha256
+        (base32 "1zcr8wi5bgvvpb5ha1v96aiaz4vqqrsn6cvvalwzah6am85k78m8"))))
     (build-system meson-build-system)
     (arguments
-     `(#:glib-or-gtk? #t
+     `(#:glib-or-gtk? #t     ; To wrap binaries and/or compile schemas
        #:phases
        (modify-phases %standard-phases
          (add-after 'glib-or-gtk-wrap 'wrap-typelib
            (lambda* (#:key outputs #:allow-other-keys)
-             (let ((prog (string-append (assoc-ref outputs "out")
-                                        "/bin/sushi")))
+             (let* ((prog (string-append (assoc-ref outputs "out")
+                                         "/bin/sushi")))
                ;; Put existing typelibs before sushi's deps, so as to correctly
                ;; infer gdk-pixbuf
                (wrap-program prog
                  `("GI_TYPELIB_PATH" suffix (,(getenv "GI_TYPELIB_PATH"))))
                #t))))))
     (native-inputs
-     `(("glib:bin" ,glib "bin")
-       ("gettext" ,gettext-minimal)
+     `(("gettext" ,gettext-minimal)
+       ("glib:bin" ,glib "bin")
        ("gobject-introspection" ,gobject-introspection)
        ("pkg-config" ,pkg-config)))
     (inputs
-     `(("clutter" ,clutter)
-       ("clutter-gst" ,clutter-gst)
-       ("clutter-gtk" ,clutter-gtk)
-       ("evince" ,evince)                         ; For file previewing.
+     `(("epoxy" ,libepoxy)
+       ("evince" ,evince)
        ("freetype" ,freetype)
-       ("gdk-pixbuf" ,gdk-pixbuf)
+       ("gdk-pixbuf" ,gdk-pixbuf+svg)
        ("gjs" ,gjs)
+       ("glib" ,glib)
        ("gst-plugins-base" ,gst-plugins-base)
        ("gstreamer" ,gstreamer)
-       ("gtksourceview" ,gtksourceview-3)
+       ("gtk+" ,gtk+)
+       ("gtksourceview" ,gtksourceview)
        ("harfbuzz" ,harfbuzz)
-       ("libepoxy" ,libepoxy)
        ("libmusicbrainz" ,libmusicbrainz)
-       ("libxml2" ,libxml2)
-       ("neon" ,neon)
        ("webkitgtk" ,webkitgtk)))
-    (synopsis "File previewer for the GNOME desktop")
+    (synopsis "File previewer")
     (description "Sushi is a DBus-activated service that allows applications to
 preview files on the GNOME desktop.")
     (home-page "https://gitlab.gnome.org/GNOME/sushi")
+    ;; With added exception clause.
     (license license:gpl2+)))
 
 (define-public rygel