summary refs log tree commit diff
path: root/gnu/packages/gnome.scm
diff options
context:
space:
mode:
authorRaghav Gururajan <raghavgururajan@disroot.org>2020-08-06 20:40:20 -0400
committerDanny Milosavljevic <dannym@scratchpost.org>2020-08-19 19:04:00 +0200
commitfc332c447ecedea7f7534f80f63e89227e774b81 (patch)
tree2975d4485cfdee67bcb28e7cce3af31e0015c888 /gnu/packages/gnome.scm
parent3d81bdd71511f9de701ac96151d36bdfab24a8c3 (diff)
downloadguix-fc332c447ecedea7f7534f80f63e89227e774b81.tar.gz
gnu: gnome-themes-extra: Update package definition.
* gnu/packages/gnome.scm (gnome-themes-extra): Update package definition.
[build-system]: Change from gnu to glib-or-gtk.
[native-inputs]: Add libxml2.
[inputs]: Add cairo, gdk-pixbuf+svg and glib. Remove libxml2.
[description]: Modify.

Signed-off-by: Danny Milosavljevic <dannym@scratchpost.org>
Diffstat (limited to 'gnu/packages/gnome.scm')
-rw-r--r--gnu/packages/gnome.scm38
1 files changed, 19 insertions, 19 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index a8364fb1c0..71c98138c8 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -12774,35 +12774,35 @@ and a high score table.")
     (source
      (origin
        (method url-fetch)
-       (uri (string-append "mirror://gnome/sources/" name "/"
-                           (version-major+minor version) "/" name "-"
-                           version ".tar.xz"))
+       (uri
+        (string-append "mirror://gnome/sources/" name "/"
+                       (version-major+minor version) "/" name "-"
+                       version ".tar.xz"))
        (sha256
-        (base32
-         "06aqg9asq2vqi9wr29bs4v8z2bf4manhbhfghf4nvw01y2zs0jvw"))))
-    (build-system gnu-build-system)
+        (base32 "06aqg9asq2vqi9wr29bs4v8z2bf4manhbhfghf4nvw01y2zs0jvw"))))
+    (build-system glib-or-gtk-build-system)
     (arguments
-     '(#:configure-flags
-       ;; Don't create 'icon-theme.cache'.
+     `(#:configure-flags
        (let* ((coreutils (assoc-ref %build-inputs "coreutils"))
-              (true      (string-append coreutils "/bin/true")))
-         (list (string-append "GTK_UPDATE_ICON_CACHE=" true)))))
+              (true (string-append coreutils "/bin/true")))
+         (list
+          (string-append "GTK_UPDATE_ICON_CACHE=" true)))))
     (native-inputs
      `(("glib:bin" ,glib "bin")
        ("intltool" ,intltool)
-       ("pkg-config" ,pkg-config)))
+       ("pkg-config" ,pkg-config)
+       ("xmllint" ,libxml2)))
     (inputs
-     `(("glib" ,glib)
+     `(("cairo" ,cairo)
+       ("gdk-pixbuf" ,gdk-pixbuf+svg)
+       ("glib" ,glib)
        ("gtk+" ,gtk+)
        ("gtk+-2" ,gtk+-2)
-       ("librsvg" ,librsvg)
-       ("libxml2" ,libxml2)))
-    (home-page "https://gitlab.gnome.org/GNOME/gnome-themes-extra")
+       ("librsvg" ,librsvg)))
     (synopsis "GNOME Extra Themes")
-    (description "This package provides themes and related elements that don't
-really fit in other upstream packages.  It offers legacy support for GTK+ 2
-versions of Adwaita, Adwaita-dark and HighContrast themes.  It also provides
-index files needed for Adwaita to be used outside of GNOME.")
+    (description "GNOME-Themes-Extra houses themes and theme-y tidbits that
+don’t really fit in anywhere else, or deserve their own module.")
+    (home-page "https://gitlab.gnome.org/GNOME/gnome-themes-extra")
     (license license:lgpl2.1+)))
 
 (define-public polari