summary refs log tree commit diff
path: root/gnu/packages/gnome.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2017-06-11 02:07:06 +0200
committerMarius Bakke <mbakke@fastmail.com>2017-06-11 02:07:06 +0200
commit5bace4c8ad981b66b5c0769b885d0bb0db91a029 (patch)
tree0f2fb95c23d7990d26aeed71590bb94a3f2e17fe /gnu/packages/gnome.scm
parent653569e878f39345b05110b998f10db3b520ccfe (diff)
parent20d87dfb453cf27f95c5ef3858e8d096278e1702 (diff)
downloadguix-5bace4c8ad981b66b5c0769b885d0bb0db91a029.tar.gz
Merge branch 'master' into core-updates
Conflicts:
* gnu/packages/tls.scm (gnutls): Incorporated 3.5.13 graft (88e2511e217f2).
Diffstat (limited to 'gnu/packages/gnome.scm')
-rw-r--r--gnu/packages/gnome.scm37
1 files changed, 35 insertions, 2 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 7dca113fe0..e277385aec 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -288,6 +288,38 @@ the GData protocol — most notably, Google's services.  It provides APIs to
 access the common Google services, and has full asynchronous support.")
     (license license:lgpl2.1+)))
 
+(define-public libgxps
+  (package
+    (name "libgxps")
+    (version "0.2.5")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append "mirror://gnome/sources/" name "/"
+                                  (version-major+minor version) "/"
+                                  name "-" version ".tar.xz"))
+              (sha256
+               (base32
+                "184r06s8g20cfigg7m169n42jjsc9wmzzlycr4g1fxxhr72r8x9y"))))
+    (build-system gnu-build-system)
+    (native-inputs
+     `(("gobject-introspection" ,gobject-introspection)
+       ("pkg-config" ,pkg-config)))
+    (inputs
+     `(("cairo" ,cairo)
+       ("glib" ,glib)
+       ("libarchive" ,libarchive)
+       ("libjpeg" ,libjpeg)
+       ("lcms" ,lcms)
+       ("libtiff" ,libtiff)
+       ("nettle" ,nettle)))
+    (home-page "https://wiki.gnome.org/Projects/libgxps")
+    (synopsis "GObject-based library for handling and rendering XPS documents")
+    (description
+     "libgxps is a GObject-based library for handling and rendering XPS
+documents.  This package also contains binaries that can convert XPS documents
+to other formats.")
+    (license license:lgpl2.1+)))
+
 (define-public gnome-common
   (package
     (name "gnome-common")
@@ -593,13 +625,14 @@ forgotten when the session ends.")
                (("gtk-update-icon-cache") "true"))
              #t)))))
     (inputs
-     `(("libspectre" ,libspectre)
+     `(("libarchive" ,libarchive)
+       ("libgxps" ,libgxps)
+       ("libspectre" ,libspectre)
        ("djvulibre" ,djvulibre)
        ("ghostscript" ,ghostscript)
        ("poppler" ,poppler)
        ("libtiff" ,libtiff)
        ;; TODO:
-       ;;   Add libgxps for XPS support.
        ;;   Build libkpathsea as a shared library for DVI support.
        ;; ("libkpathsea" ,texlive-bin)
        ("gnome-desktop" ,gnome-desktop)