summary refs log tree commit diff
path: root/gnu/packages/gnome.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2018-12-08 02:02:51 +0100
committerMarius Bakke <mbakke@fastmail.com>2018-12-08 19:37:47 +0100
commit8a831c6f0699953a878dae07250c17a34a6025bf (patch)
tree164bff2a52074a69c6f91d0dc3bd04ee0b72e98c /gnu/packages/gnome.scm
parent6fac106491e777b997e05b215fecba11808435f4 (diff)
downloadguix-8a831c6f0699953a878dae07250c17a34a6025bf.tar.gz
gnu: Remove more GCC ICE workarounds.
These were fixed with <https://bugs.gnu.org/31708>.

* gnu/packages/glib.scm (python-pygobject, python2-pygobject)[native-inputs]:
Remove GCC-7.
* gnu/packages/gnome.scm (gjs)[native-inputs]: Likewise.
[arguments]: Remove related phase.
Diffstat (limited to 'gnu/packages/gnome.scm')
-rw-r--r--gnu/packages/gnome.scm14
1 files changed, 1 insertions, 13 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index fe3c8b86ae..415398eeee 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -4633,14 +4633,6 @@ configuration program to choose applications starting on login.")
     (arguments
      '(#:phases
        (modify-phases %standard-phases
-         (add-after 'set-paths 'work-around-gcc-7-include-path-issue
-           ;; FIXME: Work around a problem with gcc-7 includes (see
-           ;; <https://bugs.gnu.org/30756>).  Note that we use gcc-7
-           ;; to work around an internal compiler error in gcc-5.
-           (lambda _
-             (unsetenv "C_INCLUDE_PATH")
-             (unsetenv "CPLUS_INCLUDE_PATH")
-             #t))
          (add-before
           'check 'pre-check
           (lambda _
@@ -4658,11 +4650,7 @@ configuration program to choose applications starting on login.")
               ((".*expect\\(datestr\\).*") ""))
             #t)))))
     (native-inputs
-     `(("gcc" ,gcc-7) ; FIXME: Work around an internal compiler error in
-                      ; gcc-5.  Try removing this when our default compiler is
-                      ; no longer gcc-5.5.0, and also remove the
-                      ; 'work-around-gcc-7-include-path-issue' phase above.
-       ("glib:bin" ,glib "bin")       ; for glib-compile-resources
+     `(("glib:bin" ,glib "bin")       ; for glib-compile-resources
        ("pkg-config" ,pkg-config)
        ("xmllint" ,libxml2)
        ;; For testing