summary refs log tree commit diff
path: root/gnu/packages/gnome.scm
diff options
context:
space:
mode:
authorJacob Hrbek <kreyren@rixotstudio.cz>2022-09-19 04:09:40 +0000
committerLudovic Courtès <ludo@gnu.org>2022-09-26 23:29:37 +0200
commitddb2b632fa1402a0a52e7f9eb53f7cc0fb79bf5d (patch)
treef84129ba0eba9cbce57ca081c6f1f67579251bb6 /gnu/packages/gnome.scm
parent4d9c9b49812cf2b8ef1da76eb43421fd73b18a72 (diff)
downloadguix-ddb2b632fa1402a0a52e7f9eb53f7cc0fb79bf5d.tar.gz
gnu: gnome-boxes: Patch 'qemu-img' file name.
* gnu/packages/gnome.scm (gnome-boxes)[arguments]: Add
'set-qemu-file-name' phase.
[inputs]: Add QEMU-MINIMAL.

Co-authored-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/gnome.scm')
-rw-r--r--gnu/packages/gnome.scm9
1 files changed, 8 insertions, 1 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 0adb065eb5..5761475c88 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -12224,7 +12224,13 @@ integrate seamlessly with the GNOME desktop.")
            #:phases #~(modify-phases %standard-phases
                         (add-after 'unpack 'disable-gtk-update-icon-cache
                           (lambda _
-                            (setenv "DESTDIR" "/"))))))
+                            (setenv "DESTDIR" "/")))
+                        (add-before 'configure 'set-qemu-file-name
+                          (lambda* (#:key inputs #:allow-other-keys)
+                            (substitute* "src/installed-media.vala"
+                              (("qemu-img")
+                               (search-input-file inputs
+                                                  "/bin/qemu-img"))))))))
     (native-inputs
      (list desktop-file-utils           ;for update-desktop-database
            gettext-minimal
@@ -12250,6 +12256,7 @@ integrate seamlessly with the GNOME desktop.")
            libvirt
            libvirt-glib
            libxml2
+           qemu-minimal                           ;for qemu-img
            sparql-query
            spice-gtk
            tracker