summary refs log tree commit diff
path: root/gnu/packages/gnome.scm
diff options
context:
space:
mode:
author宋文武 <iyzsong@gmail.com>2016-08-22 21:40:44 +0800
committer宋文武 <iyzsong@gmail.com>2016-08-23 19:46:53 +0800
commitc282c55d2267c09d2c5c203ac6c1ac45dd1224d7 (patch)
tree556233c59f324a81362f18a7c8ef48eaecac4d15 /gnu/packages/gnome.scm
parent27880b5edd627a526ba425cd75df90446cec3084 (diff)
downloadguix-c282c55d2267c09d2c5c203ac6c1ac45dd1224d7.tar.gz
gnu: file-roller: Don't install 'icon-theme.cache'
* gnu/packages/gnome.scm (file-roller)[arguments]: Add 'skip-gtk-update-icon-cache'
phase.
Diffstat (limited to 'gnu/packages/gnome.scm')
-rw-r--r--gnu/packages/gnome.scm9
1 files changed, 9 insertions, 0 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 6f1729cee0..de3d2687d0 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -3927,6 +3927,15 @@ share them with others via social networking and more.")
                (base32
                 "0cx3d8mp0pxz9wcsb2ph7g1zy22m8z5x0a4f5vgfzl0jmrcxpcy8"))))
     (build-system glib-or-gtk-build-system)
+    (arguments
+     '(#:phases
+       (modify-phases %standard-phases
+         (add-before 'install 'skip-gtk-update-icon-cache
+           (lambda _
+             ;; Don't create 'icon-theme.cache'
+             (substitute* (find-files "data" "^Makefile$")
+               (("gtk-update-icon-cache") (which "true")))
+             #t)))))
     (native-inputs
      `(("intltool" ,intltool)
        ("pkg-config" ,pkg-config)))