summary refs log tree commit diff
path: root/gnu/packages/gnome.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2019-02-24 21:17:45 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2019-02-24 21:29:23 +0100
commitc2e50474683bae26b6bc54103d83aea8cda19ebc (patch)
tree6696471879032574a6cbc01067e0ea020e78ff33 /gnu/packages/gnome.scm
parentabb90ff9877088f7b66ceddf0180920929aff4eb (diff)
downloadguix-c2e50474683bae26b6bc54103d83aea8cda19ebc.tar.gz
gnu: workrave: Update to 1.10.23.
* gnu/packages/gnome.scm (workrave): Update to 1.10.23.
[source]: Correct STRING-MAP.
Diffstat (limited to 'gnu/packages/gnome.scm')
-rw-r--r--gnu/packages/gnome.scm9
1 files changed, 5 insertions, 4 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index a01a20cfe1..0e0b30d3a7 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -7428,17 +7428,18 @@ configurable file renaming. ")
 (define-public workrave
   (package
     (name "workrave")
-    (version "1.10.21")
+    (version "1.10.23")
     (source
      (origin
        (method git-fetch)
        (uri (git-reference
              (url "https://github.com/rcaelers/workrave.git")
-             (commit (string-map (match-lambda (#\_ #\.) (chr chr)) version))))
+             (commit (string-append "v" (string-map
+                                         (match-lambda (#\. #\_) (chr chr))
+                                         version)))))
        (file-name (git-file-name name version))
        (sha256
-        (base32
-         "150qca8c552fakjlzkgarsxgp87l1xcwn19svqsa9d0cygqxjgia"))))
+        (base32 "1qhlwfhwk5agv4904d6bsf83k9k89q7bms6agg967vsca4905vcw"))))
     (build-system glib-or-gtk-build-system)
     (propagated-inputs `(("glib" ,glib)
                          ("gtk+" ,gtk+)