summary refs log tree commit diff
path: root/gnu/packages/gnome.scm
diff options
context:
space:
mode:
authorRutger Helling <rhelling@mykolab.com>2017-12-17 21:37:11 +0100
committerLudovic Courtès <ludo@gnu.org>2017-12-22 09:55:01 +0100
commitd633f2f62aa7b9f4a9a359e993cff2a2ee141ab3 (patch)
tree5f345b6a55214aca910d5c1ba394c87b503c1607 /gnu/packages/gnome.scm
parent893d0b0bf320eb20b9dd7c57eefcd2fc1371225d (diff)
downloadguix-d633f2f62aa7b9f4a9a359e993cff2a2ee141ab3.tar.gz
gnu: mutter: Add xorg-xserver-xwayland input.
* gnu/packages/gnome.scm (mutter)[inputs]: Add xorg-server-xwayland.
[arguments]: Add '--with-xwayland-path' to #:configure-flags.

Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/gnome.scm')
-rw-r--r--gnu/packages/gnome.scm6
1 files changed, 6 insertions, 0 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index b7f57b030e..2059bb4593 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -144,6 +144,7 @@
   #:use-module (gnu packages speech)
   #:use-module (gnu packages virtualization)
   #:use-module (gnu packages vpn)
+  #:use-module (gnu packages xorg)
   #:use-module (srfi srfi-1))
 
 (define-public brasero
@@ -4727,6 +4728,10 @@ to display dialog boxes from the commandline and shell scripts.")
              ;; The following flags are needed for the bundled clutter
              "--enable-x11-backend=yes"
 
+             (string-append "--with-xwayland-path="
+                            (assoc-ref %build-inputs "xorg-server-xwayland")
+                            "/bin/Xwayland")
+
              ;; the remaining flags are needed for the bundled cogl
              "--enable-cogl-gst"
              (string-append "--with-gl-libname="
@@ -4787,6 +4792,7 @@ to display dialog boxes from the commandline and shell scripts.")
        ("startup-notification" ,startup-notification)
        ("upower-glib" ,upower)
        ("xkeyboard-config" ,xkeyboard-config)
+       ("xorg-server-xwayland" ,xorg-server-xwayland)
        ("zenity" ,zenity)))
     (synopsis "Window and compositing manager")
     (home-page "https://www.gnome.org")