summary refs log tree commit diff
path: root/gnu/packages/gnome.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2019-03-14 15:06:06 +0100
committerMarius Bakke <mbakke@fastmail.com>2019-03-14 15:06:06 +0100
commitebfe259f6682b43d7f0d3b57b525e25f97410052 (patch)
treee3f09eb6159168e1736f8a629286eb3d148917a9 /gnu/packages/gnome.scm
parent47b3eed821cf86c350dc4b0fdbe75647cdc275b0 (diff)
parent8cc3983a4d02a15ad4a863671c1a5a8b2b542625 (diff)
downloadguix-ebfe259f6682b43d7f0d3b57b525e25f97410052.tar.gz
Merge branch 'master' into staging
Diffstat (limited to 'gnu/packages/gnome.scm')
-rw-r--r--gnu/packages/gnome.scm74
1 files changed, 34 insertions, 40 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index c6447d2450..ea042612e1 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -2596,7 +2596,7 @@ libxml to ease remote use of the RESTful API.")
 (define-public libsoup
   (package
     (name "libsoup")
-    (version "2.64.2")
+    (version "2.66.0")
     (source (origin
               (method url-fetch)
               (uri (string-append "mirror://gnome/sources/libsoup/"
@@ -2604,38 +2604,23 @@ libxml to ease remote use of the RESTful API.")
                                   name "-" version ".tar.xz"))
               (sha256
                (base32
-                "1il6lyrmfi0hfh3ysw8w1qzc1rdz0igkb7dv6d8g5mmilnac3pbm"))))
-    (build-system gnu-build-system)
+                "08c9kkdhzy504gv23pfdm4sq3dd3j20sikwz6gv0qrwcdjnw5bai"))))
+    (build-system meson-build-system)
     (outputs '("out" "doc"))
     (arguments
      `(#:modules ((guix build utils)
-                  (guix build gnu-build-system)
+                  (guix build meson-build-system)
                   (ice-9 popen))
 
-       #:configure-flags
-       (list (string-append "--with-html-dir="
-                            (assoc-ref %outputs "doc")
-                            "/share/gtk-doc/html")
-             (string-append "--with-apache-module-dir="
-                            (assoc-ref %build-inputs "httpd")
-                            "/modules"))
+       #:configure-flags '("-Ddoc=true")
        #:phases
        (modify-phases %standard-phases
-         (add-before 'configure 'disable-unconnected-socket-test
-           ;; This test fails due to missing /etc/nsswitch.conf
-           ;; in the build environment.
+         (add-after 'unpack 'adjust-tests
            (lambda _
+             ;; This test fails due to missing /etc/nsswitch.conf
+             ;; in the build environment.
              (substitute* "tests/socket-test.c"
                ((".*/sockets/unconnected.*") ""))
-             #t))
-         (add-before 'check 'pre-check
-           (lambda _
-             ;; The 'check-local' target runs 'env LANG=C sort -u',
-             ;; unset 'LC_ALL' to make 'LANG' working.
-             (unsetenv "LC_ALL")
-             ;; HTTPD in Guix uses mod_event and does not build prefork.
-             (substitute* "tests/httpd.conf"
-               (("^LoadModule mpm_prefork_module.*$") "\n"))
 
              ;; Generate a self-signed certificate that has "localhost" as its
              ;; 'dnsName'.  Failing to do that, and starting with GnuTLS
@@ -2681,16 +2666,19 @@ libxml to ease remote use of the RESTful API.")
                            ))
                (close-pipe pipe))
              #t))
-         (replace 'install
-           (lambda _
-             (invoke "make"
-                     ;; Install vala bindings into $out.
-                     (string-append "vapidir=" %output
-                                    "/share/vala/vapi")
-                     "install"))))))
+         (add-after 'install 'move-doc
+           (lambda* (#:key outputs #:allow-other-keys)
+             (let ((out (assoc-ref outputs "out"))
+                   (doc (assoc-ref outputs "doc")))
+               (mkdir-p (string-append doc "/share"))
+               (copy-recursively (string-append out "/share/gtk-doc")
+                                 (string-append doc "/share/gtk-doc"))
+               (delete-file-recursively (string-append out "/share/gtk-doc"))
+               #t))))))
     (native-inputs
      `(("glib:bin" ,glib "bin")                   ; for glib-mkenums
        ("gobject-introspection" ,gobject-introspection)
+       ("gtk-doc" ,gtk-doc)
        ("intltool" ,intltool)
        ("pkg-config" ,pkg-config)
        ("python" ,python-wrapper)
@@ -2703,11 +2691,12 @@ libxml to ease remote use of the RESTful API.")
     (propagated-inputs
      ;; libsoup-2.4.pc refers to all these.
      `(("glib" ,glib)
-       ("libxml2" ,libxml2)))
-    (inputs
-     `(("glib-networking" ,glib-networking)
        ("libpsl" ,libpsl)
+       ("libxml2" ,libxml2)
        ("sqlite" ,sqlite)))
+    (inputs
+     `(("glib-networking" ,glib-networking)
+       ("mit-krb5" ,mit-krb5)))
     (home-page "https://live.gnome.org/LibSoup/")
     (synopsis "GLib-based HTTP Library")
     (description
@@ -4304,7 +4293,7 @@ work and the interface is well tested.")
        ("libsecret" ,libsecret)
        ("gtkspell3" ,gtkspell3)
        ("gsettings-desktop-schemas" ,gsettings-desktop-schemas)
-       ("webkitgtk" ,webkitgtk-2.22)))
+       ("webkitgtk" ,webkitgtk-2.24)))
     (home-page "https://wiki.gnome.org/Apps/Eolie")
     (synopsis "Web browser for GNOME")
     (description
@@ -4363,7 +4352,7 @@ a secret password store, an adblocker, and a modern UI.")
        ("libxslt" ,libxslt)
        ("nettle" ,nettle) ; for hogweed
        ("sqlite" ,sqlite)
-       ("webkitgtk" ,webkitgtk-2.22)))
+       ("webkitgtk" ,webkitgtk-2.24)))
     (home-page "https://wiki.gnome.org/Apps/Web")
     (synopsis "GNOME web browser")
     (description
@@ -5215,7 +5204,7 @@ users.")
              (doc      (assoc-ref %outputs "doc"))
              (dhclient (string-append (assoc-ref %build-inputs "isc-dhcp")
                                       "/sbin/dhclient")))
-         (list "--with-systemd-logind=yes" ;In GuixSD, this is provided by elogind.
+         (list "--with-systemd-logind=yes" ;In Guix System, this is provided by elogind.
                "--with-consolekit=no"
                "--with-crypto=gnutls"
                "--disable-config-plugin-ibft"
@@ -5766,10 +5755,9 @@ properties, screen resolution, and other GNOME parameters.")
                    (copy-file #$(file-append %artwork-repository
                                              "/slim/0.x/background.png")
                               "data/theme/guix-background.png")
-                   (invoke #+(file-append inkscape "/bin/inkscape")
-                           "--export-png=data/theme/guix-logo.png"
-                           #$(file-append %artwork-repository
-                                          "/logo/Guix-horizontal-white.svg"))
+                   (copy-file #$(file-append %artwork-repository
+                                             "/logo/Guix-horizontal-white.svg")
+                              "data/theme/guix-logo.svg")
                    #t))))
     (build-system meson-build-system)
     (arguments
@@ -5791,6 +5779,11 @@ properties, screen resolution, and other GNOME parameters.")
                  (("keysdir =.*")
                   (string-append "keysdir = '" keysdir "'\n")))
                #t)))
+         (add-before 'configure 'convert-logo-to-png
+           (lambda* (#:key inputs #:allow-other-keys)
+             ;; Convert the logo from SVG to PNG.
+             (invoke "inkscape" "--export-png=data/theme/guix-logo.png"
+                     "data/theme/guix-logo.svg")))
          (add-before 'check 'pre-check
            (lambda* (#:key inputs #:allow-other-keys)
              ;; Tests require a running X server.
@@ -5822,6 +5815,7 @@ properties, screen resolution, and other GNOME parameters.")
      `(("glib:bin" ,glib "bin") ; for glib-compile-schemas, etc.
        ("desktop-file-utils" ,desktop-file-utils) ; for update-desktop-database
        ("gobject-introspection" ,gobject-introspection)
+       ("inkscape" ,inkscape)
        ("intltool" ,intltool)
        ("pkg-config" ,pkg-config)
        ("python" ,python)