summary refs log tree commit diff
path: root/gnu/packages/gnome.scm
diff options
context:
space:
mode:
authorLiliana Marie Prikler <liliana.prikler@gmail.com>2021-12-14 22:01:48 +0100
committerLiliana Marie Prikler <liliana.prikler@gmail.com>2021-12-15 20:24:25 +0100
commit6454884027084fa62d645b74ca835adfe6882f57 (patch)
treeac67d3524ded7be689e1e45a3e001f75a1ecd3a4 /gnu/packages/gnome.scm
parent3eadcdc63eb4ea16eb4dc1e8ee7fb369e04ffb52 (diff)
downloadguix-6454884027084fa62d645b74ca835adfe6882f57.tar.gz
gnu: gitg: Fix compilation.
* gnu/packages/gnome.scm (gitg)[#:meson]: Use meson-0.59.
[#:phases] Add ‘harden’ phase to fix test failures.
[inputs]: Use libsoup-minimal-2.
Diffstat (limited to 'gnu/packages/gnome.scm')
-rw-r--r--gnu/packages/gnome.scm18
1 files changed, 16 insertions, 2 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 5f46eb4d63..7c74b4a874 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -11294,7 +11294,8 @@ higher level porcelain stuff.")
                 "0npg4kqpwl992fgjd2cn3fh84aiwpdp9kd8z7rw2xaj2iazsm914"))))
     (build-system meson-build-system)
     (arguments
-     `(#:glib-or-gtk? #t
+     `(#:meson ,meson-0.59
+       #:glib-or-gtk? #t
        #:phases
        (modify-phases %standard-phases
          (add-after 'unpack 'disable-post-install-partially
@@ -11309,6 +11310,19 @@ higher level porcelain stuff.")
              (substitute* "tests/libgitg/test-commit.vala"
                (("/bin/bash") (which "bash")))
              #t))
+         ;; XXX: Remove upon next version bump
+         (add-after 'unpack 'harden
+           (lambda _
+             ;; See <https://gitlab.gnome.org/GNOME/gitg/-/issues/337>
+             (substitute* "libgitg/gitg-date.vala"
+               (("(val\|tzs) == null" all val)
+                (string-append val " == null || " val " == \"\""))
+               (("(val\|tzs) != null" all val)
+                (string-append val " != null && " val " != \"\"")))
+             ;; See <https://gitlab.gnome.org/GNOME/gitg/-/merge_requests/159>
+             (substitute* "gitg/gitg-action-support.vala"
+               (("stash_if_needed\\((.*), Gitg.Ref head" all other)
+                (string-append "stash_if_needed(" other ", Gitg.Ref? head")))))
          (add-after 'glib-or-gtk-wrap 'wrap-typelib
            (lambda* (#:key outputs #:allow-other-keys)
              (let ((prog (string-append (assoc-ref outputs "out")
@@ -11328,7 +11342,7 @@ higher level porcelain stuff.")
            libgit2-glib
            libpeas
            libsecret
-           libsoup
+           libsoup-minimal-2
            libxml2))
     (native-inputs
      `(("glib:bin" ,glib "bin")