summary refs log tree commit diff
path: root/gnu/packages/gnome.scm
diff options
context:
space:
mode:
authorTimothy Sample <samplet@ngyro.com>2017-10-23 20:44:47 -0400
committerLudovic Courtès <ludo@gnu.org>2017-11-07 18:09:13 +0100
commit950d8e5d8ca5971c93082a9bdc4415fa20568e21 (patch)
treee63dabe4f60bc037cf02ea136801f7198844491c /gnu/packages/gnome.scm
parent25a5b187e8f3efe4b80fd2d005b04d89e1a85d67 (diff)
downloadguix-950d8e5d8ca5971c93082a9bdc4415fa20568e21.tar.gz
gnu: gdm: Fix config file path.
* gnu/packages/gnome.scm (gdm)[arguments]<#:phases>: Fix the
'pre-configure phase so that GDM finds its config file.

Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/gnome.scm')
-rw-r--r--gnu/packages/gnome.scm4
1 files changed, 2 insertions, 2 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 6162b2fcca..35c40f233c 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -5282,9 +5282,9 @@ libxml2.")
                 "    \"/run/current-system/profile/etc/xdg\");\n"
                 )))
             ;; Look for custom GDM conf in /run/current-system.
-            (substitute* '("common/gdm-settings-backend.c")
+            (substitute* '("common/gdm-settings-desktop-backend.c")
               (("GDM_CUSTOM_CONF")
-               "/run/current-system/etc/gdm/custom.conf"))
+               "\"/run/current-system/etc/gdm/custom.conf\""))
             ;; Use service-supplied path to X.
             (substitute* '("daemon/gdm-server.c")
               (("\\(X_SERVER X_SERVER_ARG_FORMAT")