summary refs log tree commit diff
path: root/gnu/packages/gnome.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2014-07-02 11:42:17 +0200
committerLudovic Courtès <ludo@gnu.org>2014-07-02 11:42:17 +0200
commit44add1ce19473990654b399c2a83707b3b76034b (patch)
treed717070be5aa0d1dfeba82ed85cc606899b6632a /gnu/packages/gnome.scm
parent426adbe82731b8b4968cad8d474545d3e8b55c65 (diff)
downloadguix-44add1ce19473990654b399c2a83707b3b76034b.tar.gz
gnu: Adjust more packages to GLib "bin" split.
* gnu/packages/glib.scm (dbus-glib): Add glib-bin to 'native-inputs'.
  (glibmm): Likewise.
* gnu/packages/gstreamer.scm (gstreamer-0.10): Likewise.
* gnu/packages/gtk.scm (gtksourceview): Likewise.
* gnu/packages/qemu.scm (qemu-headless): Likewise.
* gnu/packages/gnome.scm (librsvg, libbonobo, libgnomecanvas,
  libgnomeprint): Likewise.
Diffstat (limited to 'gnu/packages/gnome.scm')
-rw-r--r--gnu/packages/gnome.scm8
1 files changed, 6 insertions, 2 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index dd407c5eeb..fa96ab1763 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -598,6 +598,7 @@ dealing with different structured file formats.")
         %standard-phases)))
     (native-inputs
      `(("pkg-config" ,pkg-config)
+       ("glib" ,glib "bin")                               ; glib-mkenums, etc.
        ("gobject-introspection" ,gobject-introspection))) ; g-ir-compiler, etc.
     (inputs
      `(("pango" ,pango)
@@ -713,12 +714,13 @@ featuring mature C, C++ and Python bindings.")
     (inputs `(("popt" ,popt)
               ("libxml2" ,libxml2)))
     ;; The following are Required by the .pc file
-    (propagated-inputs  
+    (propagated-inputs
      `(("glib" ,glib)
        ("orbit2" ,orbit2)))
     (native-inputs
      `(("intltool" ,intltool)
        ("pkg-config" ,pkg-config)
+       ("glib" ,glib "bin")
        ("flex" ,flex)
        ("bison" ,bison)))
     (home-page "https://developer.gnome.org/libbonobo/")
@@ -922,6 +924,7 @@ high-quality vector-based 2D library with antialiasing and alpha composition.")
                          ("gtk+" ,gtk+-2)))
     (native-inputs
      `(("intltool" ,intltool)
+       ("glib" ,glib "bin")
        ("pkg-config" ,pkg-config)))
     (home-page "https://developer.gnome.org/libgnomecanvas/")
     (synopsis "Flexible widget for creating interactive structured graphics")
@@ -1007,9 +1010,10 @@ widgets built in the loading process.")
      `(("popt" ,popt)
        ("libart-lgpl" ,libart-lgpl)
        ("gtk+" ,gtk+-2)
-       ("libxml2" ,libxml2))) 
+       ("libxml2" ,libxml2)))
     (native-inputs
      `(("intltool" ,intltool)
+       ("glib" ,glib "bin")
        ("pkg-config" ,pkg-config)))
     (home-page "https://projects.gnome.org/gnome-print/home/faq.html")
     (synopsis "printing framework for GNOME")