summary refs log tree commit diff
path: root/gnu/packages/gnome.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2019-06-05 19:46:16 +0200
committerMarius Bakke <mbakke@fastmail.com>2019-06-05 19:46:16 +0200
commitd4721ff1017b64e5242b09fd7b430665ec580524 (patch)
tree1bd9ce1a339f5b348e780e4bb7f53a4333bfce01 /gnu/packages/gnome.scm
parent30e12b9664d774aca3948b1fa2e0aee6af09ca40 (diff)
parentc0f6eebb6d9f6ca9b62344f32ce5f82dab601d53 (diff)
downloadguix-d4721ff1017b64e5242b09fd7b430665ec580524.tar.gz
Merge branch 'master' into staging
Diffstat (limited to 'gnu/packages/gnome.scm')
-rw-r--r--gnu/packages/gnome.scm9
1 files changed, 6 insertions, 3 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index f1952be840..43b8934fb2 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -4320,15 +4320,15 @@ work and the interface is well tested.")
 (define-public eolie
   (package
     (name "eolie")
-    (version "0.9.60")
+    (version "0.9.62")
     (source (origin
               (method url-fetch)
               (uri (string-append "https://gitlab.gnome.org/World/eolie/"
-                                  "uploads/3b2ceb7eb15860587db6886bfdd8a91e/"
+                                  "uploads/bb4aad19272cc636bd17f2f6602127fe/"
                                   "eolie-" version ".tar.xz"))
               (sha256
                (base32
-                "1s9gkzxa6457v6bh0q8n1ijq1chd2jwgvhk5kppsnya7kxvsx8qh"))))
+                "06v76hg87fnhw45dil5vvl20myvaa38n1jqsl0lmkkq6af4mk8wx"))))
     (build-system meson-build-system)
     (arguments
      `(#:glib-or-gtk? #t
@@ -5881,6 +5881,9 @@ devices using the GNOME desktop.")
                  (("\"nm-connection-editor")
                   (string-append "\"" nm-applet
                                  "/bin/nm-connection-editor")))
+               (substitute* '("panels/user-accounts/run-passwd.c")
+                 (("/usr/bin/passwd")
+                  "/run/setuid-programs/passwd"))
                #t))))))
     (native-inputs
      `(("glib:bin" ,glib "bin") ; for glib-mkenums, etc.