summary refs log tree commit diff
path: root/gnu/packages/gnome.scm
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2022-01-11 00:11:14 +0100
committerMarius Bakke <marius@gnu.org>2022-01-11 18:36:39 +0100
commitd695a63ec9feac903ecf49e8d993df357d4837f9 (patch)
tree1701bbe05b7cdaf6b13c30609d529398e9631c9f /gnu/packages/gnome.scm
parent81cbf8854a8407292e3ef2c20d37c4a2cecea2df (diff)
downloadguix-d695a63ec9feac903ecf49e8d993df357d4837f9.tar.gz
gnu: authenticator: Remove input labels.
* gnu/packages/gnome.scm (authenticator)[native-inputs]: Remove labels.
[arguments]: While at it, remove top-level Python reference in favor of
THIS-PACKAGE-INPUT.
[inputs]: Add PYTHON.
Diffstat (limited to 'gnu/packages/gnome.scm')
-rw-r--r--gnu/packages/gnome.scm19
1 files changed, 10 insertions, 9 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index d1f791eb16..60e79a7039 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -9607,24 +9607,25 @@ specified duration and save it as a GIF encoded animated image file.")
                    (pylib (string-append (assoc-ref outputs "out")
                                          "/lib/python"
                                          ,(version-major+minor
-                                           (package-version python))
+                                           (package-version
+                                            (this-package-input "python")))
                                          "/site-packages")))
                (wrap-program prog
                  `("GUIX_PYTHONPATH" = (,(getenv "GUIX_PYTHONPATH") ,pylib))
-                 `("GI_TYPELIB_PATH" = (,(getenv "GI_TYPELIB_PATH"))))
-               #t))))))
+                 `("GI_TYPELIB_PATH" = (,(getenv "GI_TYPELIB_PATH"))))))))))
     (native-inputs
-     `(("desktop-file-utils" ,desktop-file-utils)
-       ("gettext" ,gettext-minimal)
-       ("glib:bin" ,glib "bin")
-       ("gobject-introspection" ,gobject-introspection)
-       ("gtk+:bin" ,gtk+ "bin")
-       ("pkg-config" ,pkg-config)))
+     (list desktop-file-utils
+           gettext-minimal
+           `(,glib "bin")
+           gobject-introspection
+           `(,gtk+ "bin")
+           pkg-config))
     (inputs
      (list gsettings-desktop-schemas
            gtk+
            libhandy-0.0
            libsecret
+           python
            python-beautifulsoup4
            python-pillow
            python-pyfavicon