summary refs log tree commit diff
path: root/gnu/packages/gnome.scm
diff options
context:
space:
mode:
authorLiliana Marie Prikler <liliana.prikler@gmail.com>2022-01-23 10:41:44 +0100
committerJulien Lepiller <julien@lepiller.eu>2022-02-08 13:53:22 +0100
commite086b0807b079df58d5607770ecd5ec8c480f093 (patch)
tree162caf4d9383fc7d4b299461fcfd7546f38d785a /gnu/packages/gnome.scm
parent4be896d6e0d322b3f5b514c8a2811efcd6a31606 (diff)
downloadguix-e086b0807b079df58d5607770ecd5ec8c480f093.tar.gz
gnu: evolution-data-server: Build with libphonenumber.
* gnu/packages/gnome.scm (evolution)[#:configure-flags]: Drop
inexistent flags.  Add "-DWITH_PHONENUMBER=ON".
[native-inputs]: Add protobuf.
[inputs]: Add boost and libphonenumber.

Signed-off-by: Julien Lepiller <julien@lepiller.eu>
Diffstat (limited to 'gnu/packages/gnome.scm')
-rw-r--r--gnu/packages/gnome.scm11
1 files changed, 7 insertions, 4 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 92900c8421..beab19805b 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -158,6 +158,7 @@
   #:use-module (gnu packages mail)
   #:use-module (gnu packages man)
   #:use-module (gnu packages markup)
+  #:use-module (gnu packages messaging)
   #:use-module (gnu packages mp3)
   #:use-module (gnu packages multiprecision)
   #:use-module (gnu packages music)
@@ -7680,14 +7681,13 @@ Microsoft Exchange, Last.fm, IMAP/SMTP, Jabber, SIP and Kerberos.")
                              '("addressbook-backends" "calendar-backends"
                                "camel-providers" "credential-modules"
                                "registry-modules"))))
-         (list "-DENABLE_UOA=OFF"             ;disable Ubuntu Online Accounts support
-               "-DENABLE_GOOGLE=OFF"          ;disable Google Contacts support
-               "-DENABLE_GOOGLE_AUTH=OFF"     ;disable Google authentication
+         (list "-DENABLE_GOOGLE=OFF"          ;disable Google Contacts support
                "-DENABLE_VALA_BINDINGS=ON"
                (string-append "-DCMAKE_INSTALL_RPATH=" lib ";"
                               (string-append lib "/evolution-data-server;")
                               (string-join runpaths ";"))
-               "-DENABLE_INTROSPECTION=ON"))  ;required for Vala bindings
+               "-DENABLE_INTROSPECTION=ON" ;required for Vala bindings
+               "-DWITH_PHONENUMBER=ON"))
        #:phases
        (modify-phases %standard-phases
          (add-after 'unpack 'disable-failing-tests
@@ -7717,6 +7717,7 @@ Microsoft Exchange, Last.fm, IMAP/SMTP, Jabber, SIP and Kerberos.")
        ("gsettings-desktop-schemas" ,gsettings-desktop-schemas)
        ("intltool" ,intltool)
        ("pkg-config" ,pkg-config)
+       ("protobuf" ,protobuf)
        ("vala" ,vala)
        ("python" ,python-wrapper)))
     (propagated-inputs
@@ -7729,11 +7730,13 @@ Microsoft Exchange, Last.fm, IMAP/SMTP, Jabber, SIP and Kerberos.")
        ("sqlite" ,sqlite)))
     (inputs
      `(("bdb" ,bdb)
+       ("boost" ,boost)
        ("gcr" ,gcr)
        ("gnome-online-accounts:lib" ,gnome-online-accounts "lib")
        ("json-glib" ,json-glib)
        ("libcanberra" ,libcanberra)
        ("libgweather" ,libgweather)
+       ("libphonenumber" ,libphonenumber)
        ("mit-krb5" ,mit-krb5)
        ("openldap" ,openldap)
        ("webkitgtk" ,webkitgtk-with-libsoup2)))