summary refs log tree commit diff
path: root/gnu/packages/gnome.scm
diff options
context:
space:
mode:
authorLiliana Marie Prikler <liliana.prikler@gmail.com>2022-01-23 12:07:20 +0100
committerLiliana Marie Prikler <liliana.prikler@gmail.com>2022-01-23 12:10:37 +0100
commitee751690ce7c6b29b168e6262ab82015c4a70500 (patch)
treeac6a1473c71825c3cc1dbf5ee74c847558e4ad8d /gnu/packages/gnome.scm
parent413a7a1c56db98f06451b991902ecd087e467df4 (diff)
downloadguix-ee751690ce7c6b29b168e6262ab82015c4a70500.tar.gz
gnu: gnome-builder: Fix build.
* gnu/packages/patches/gnome-builder-update-libportal.patch: New file.
* gnu/local.mk (dist_patch_DATA): Add it here.
* gnu/packages/gnome.scm (gnome-builder)[patches]: Use it here.
[inputs, native-inputs]: Add python.
Diffstat (limited to 'gnu/packages/gnome.scm')
-rw-r--r--gnu/packages/gnome.scm6
1 files changed, 5 insertions, 1 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index ad7536c07c..e052bb2dee 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -12331,7 +12331,9 @@ libraries.  Applications do not need to be recompiled--or even restarted.")
                                   name "-" version ".tar.xz"))
               (sha256
                (base32
-                "04p031i999dccbnlbysmr6f93x7dji7b559j6yhdsqbqgxb7ncan"))))
+                "04p031i999dccbnlbysmr6f93x7dji7b559j6yhdsqbqgxb7ncan"))
+              (patches
+               (search-patches "gnome-builder-update-libportal.patch"))))
     (build-system meson-build-system)
     (arguments
      `(#:glib-or-gtk? #t     ; To wrap binaries and compile schemas
@@ -12379,6 +12381,7 @@ libraries.  Applications do not need to be recompiled--or even restarted.")
        ("libportal" ,libportal)
        ("libsoup" ,libsoup-minimal-2)
        ("llvm" ,llvm)
+       ("python" ,python)
        ("python-pygobject" ,python-pygobject)
        ("sysprof" ,sysprof)
        ("template-glib" ,template-glib)
@@ -12391,6 +12394,7 @@ libraries.  Applications do not need to be recompiled--or even restarted.")
        ("glib:bin" ,glib "bin")
        ("gettext" ,gettext-minimal)
        ("pkg-config" ,pkg-config)
+       ("python" ,python)
        ("vala" ,vala)
        ("xorg-server" ,xorg-server-for-tests)))
     (home-page "https://wiki.gnome.org/Apps/Builder")