summary refs log tree commit diff
path: root/gnu/packages/gnome.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2019-11-27 22:19:13 +0100
committerMarius Bakke <mbakke@fastmail.com>2019-11-28 00:33:47 +0100
commitff3375251d6a316e3ee05589d70a8bb135ec47a6 (patch)
tree3bb25cc788c63f336687451a3337f681cc669bd3 /gnu/packages/gnome.scm
parentdcc7fad0016d7ef062ccfe0b1deb3368251e8ff8 (diff)
downloadguix-ff3375251d6a316e3ee05589d70a8bb135ec47a6.tar.gz
gnu: Use the test-only Xorg variant for tests.
* gnu/packages/education.scm (gcompris-qt)[native-inputs]: Change XORG-SERVER
to XORG-SERVER-FOR-TESTS.
* gnu/packages/engineering.scm (pcb, qucs, openscad)[native-inputs]: Likewise.
* gnu/packages/gnome.scm (libbonoboui, d-feet, gspell, libdazzle, libhandy)[native-inputs]: Likewise.
* gnu/packages/gnupg.scm (parcimonie)[native-inputs]: Likewise.
* gnu/packages/graphics.scm (opensubdiv, rapicorn)[native-inputs]: Likewise.
* gnu/packages/gtk.scm (gtksourceview-2, gtksourceview)[native-inputs]: Likewise.
* gnu/packages/image-processing.scm (opencv)[native-inputs]: Likewise.
* gnu/packages/kde-frameworks.scm (kconfig, kcoreaddons, kwidgetsaddons,
kwindowsystem, kdeclarative)[native-inputs]: Likewise.
* gnu/packages/kde-plasma.scm (kscreenlocker)[native-inputs]: Likewise.
* gnu/packages/messaging.scm (gajim)[native-inputs]: Likewise.
* gnu/packages/python-xyz.scm (python-seaborn)[native-inputs]: Likewise.
Diffstat (limited to 'gnu/packages/gnome.scm')
-rw-r--r--gnu/packages/gnome.scm10
1 files changed, 5 insertions, 5 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index af2558d814..11ed035919 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -2025,7 +2025,7 @@ since ca. 2006, when GTK+ itself incorporated printing support.")
     (native-inputs
      `(("glib" ,glib "bin")             ; for glib-genmarshal, etc.
        ("intltool" ,intltool)
-       ("xorg-server" ,xorg-server) ; For running the tests
+       ("xorg-server" ,xorg-server-for-tests) ; For running the tests
        ("pkg-config" ,pkg-config)))
     (home-page "https://developer.gnome.org/libbonoboui/")
     (synopsis "Some user interface controls using Bonobo")
@@ -4591,7 +4591,7 @@ principles are simplicity and standards compliance.")
        ("pkg-config" ,pkg-config)
        ("python-pep8" ,python-pep8)
        ("xmllint" ,libxml2)
-       ("xorg-server" ,xorg-server)))
+       ("xorg-server" ,xorg-server-for-tests)))
     (inputs
      `(("gobject-introspection" ,gobject-introspection)
        ("gtk+" ,gtk+)
@@ -7752,7 +7752,7 @@ that support the Assistive Technology Service Provider Interface (AT-SPI).")
 
        ;; For tests.
        ("aspell-dict-en" ,aspell-dict-en)
-       ("xorg-server" ,xorg-server)))
+       ("xorg-server" ,xorg-server-for-tests)))
     (propagated-inputs
      `(("enchant" ,enchant)))            ;enchant.pc is required by gspell-1.pc
     (home-page "https://wiki.gnome.org/Projects/gspell")
@@ -8167,7 +8167,7 @@ hexadecimal or ASCII.  It is useful for editing binary files in general.")
      `(("glib" ,glib "bin")             ; glib-compile-resources
        ("pkg-config" ,pkg-config)
        ;; For tests.
-       ("xorg-server" ,xorg-server)))
+       ("xorg-server" ,xorg-server-for-tests)))
     (inputs
      `(("glib" ,glib)
        ("gobject-introspection" ,gobject-introspection)
@@ -8389,9 +8389,9 @@ advanced image management tool")
        ("gtk-doc" ,gtk-doc)
        ("pkg-config" ,pkg-config)
        ("gettext" ,gettext-minimal)
-       ("xorg-server" ,xorg-server)
 
        ;; Test suite dependencies.
+       ("xorg-server" ,xorg-server-for-tests)
        ("hicolor-icon-theme" ,hicolor-icon-theme)))
     (home-page "https://source.puri.sm/Librem5/libhandy")
     (synopsis "Library full of GTK+ widgets for mobile phones")