summary refs log tree commit diff
path: root/gnu/packages/gnunet.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2015-11-06 16:07:07 +0100
committerLudovic Courtès <ludo@gnu.org>2015-11-06 23:50:14 +0100
commit59698c2c6c0f3471c4fecca03f44dc969f67d95f (patch)
treead8a88ed918930dfa34d78a8d7b1cfad3a83cd2f /gnu/packages/gnunet.scm
parent4d75e03ac9cdea393dd29758fbfe8ec003326f7c (diff)
downloadguix-59698c2c6c0f3471c4fecca03f44dc969f67d95f.tar.gz
gnu: Add guile-gnunet.
* gnu/packages/gnunet.scm (guile-gnunet): New variable.
Diffstat (limited to 'gnu/packages/gnunet.scm')
-rw-r--r--gnu/packages/gnunet.scm34
1 files changed, 34 insertions, 0 deletions
diff --git a/gnu/packages/gnunet.scm b/gnu/packages/gnunet.scm
index 6d1a1a86bc..aac1567cf3 100644
--- a/gnu/packages/gnunet.scm
+++ b/gnu/packages/gnunet.scm
@@ -29,6 +29,7 @@
   #:use-module (gnu packages glib)
   #:use-module (gnu packages gnupg)
   #:use-module (gnu packages groff)
+  #:use-module (gnu packages guile)
   #:use-module (gnu packages gstreamer)
   #:use-module (gnu packages libidn)
   #:use-module (gnu packages image)
@@ -45,6 +46,7 @@
   #:use-module ((guix licenses) #:prefix license:)
   #:use-module (guix packages)
   #:use-module (guix download)
+  #:use-module (guix git-download)
   #:use-module (guix build-system gnu))
 
 (define-public libextractor
@@ -250,3 +252,35 @@ applications.  In particular, GNUnet now includes the GNU Name System, a
 privacy-preserving, decentralized public key infrastructure.")
    (license license:gpl3+)
    (home-page "https://gnunet.org/")))
+
+(define-public guile-gnunet                       ;GSoC 2015!
+  (let ((commit "383eac2"))
+    (package
+      (name "guile-gnunet")
+      (version (string-append "0.0." commit))
+      (source (origin
+                (method git-fetch)
+                (uri (git-reference
+                      (url "git://git.sv.gnu.org/guix/gnunet.git")
+                      (commit commit)))
+                (sha256
+                 (base32
+                  "0k6mn28isjlxrnvbnblab3nh2xqx1b7san8k98kc35ap9lq0iz8w"))))
+      (build-system gnu-build-system)
+      (arguments
+       '(#:phases (modify-phases %standard-phases
+                    (add-before 'configure 'bootstrap
+                      (lambda _
+                        (zero? (system* "autoreconf" "-vfi")))))))
+      (native-inputs `(("pkg-config" ,pkg-config)
+                       ("autoconf" ,(autoconf-wrapper))
+                       ("automake" ,automake)))
+      (inputs `(("guile" ,guile-2.0)
+                ("gnunet" ,gnunet)))
+      (synopsis "Guile bindings for GNUnet services")
+      (description
+       "This package provides Guile bindings to the client libraries of various
+GNUnet services, including the @dfn{identity} and @dfn{file sharing}
+services.")
+      (home-page "http://gnu.org/software/guix")
+      (license license:gpl3+))))