summary refs log tree commit diff
path: root/gnu/packages/gnupg.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2023-12-11 23:11:26 +0100
committerLudovic Courtès <ludo@gnu.org>2023-12-11 23:11:26 +0100
commit7217c9348679d00ebf80fe5285564f6bb198a8fd (patch)
tree374295df1a7cbf1f00ae3cef7a054429eb23677e /gnu/packages/gnupg.scm
parent4bf4e340b74b66a0fc319aeb100fb1f948a67211 (diff)
downloadguix-7217c9348679d00ebf80fe5285564f6bb198a8fd.tar.gz
gnu: libgpg-error: Do not assume that target is a triplet.
Fixes a bug exposed with be5ec2ebb4bde4b4f702a30f08849dff05cceccd, which
introduces the “avr” target, which has no hyphen.

* gnu/packages/gnupg.scm (libgpg-error)[arguments]: In ‘cross-symlinks’
phase, adjust code to deal with TARGET lacking a hyphen.

Change-Id: I1aff6a94a7c92626f931c459d1dc0509f9bcfc00
Diffstat (limited to 'gnu/packages/gnupg.scm')
-rw-r--r--gnu/packages/gnupg.scm9
1 files changed, 4 insertions, 5 deletions
diff --git a/gnu/packages/gnupg.scm b/gnu/packages/gnupg.scm
index a5b8587a14..2b6a5ec796 100644
--- a/gnu/packages/gnupg.scm
+++ b/gnu/packages/gnupg.scm
@@ -1,5 +1,5 @@
 ;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2012, 2013, 2014, 2015, 2016, 2017, 2018, 2019, 2020, 2021 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2012-2021, 2023 Ludovic Courtès <ludo@gnu.org>
 ;;; Copyright © 2013, 2015, 2018 Andreas Enge <andreas@enge.fr>
 ;;; Copyright © 2014, 2018 Eric Bavier <bavier@member.fsf.org>
 ;;; Copyright © 2014, 2015, 2016, 2020 Mark H Weaver <mhw@netris.org>
@@ -130,11 +130,10 @@
                   (symlink (string-append "lock-obj-pub." triplet ".h")
                            (string-append "src/syscfg/lock-obj-pub."
                                           source ".h")))
-                #$(let* ((target (%current-target-system))
-                         (architecture
-                          (string-take target (string-index target #\-))))
+                #$(let ((target (%current-target-system)))
                     (cond ((target-linux? target)
-                           (match architecture
+                           (match (string-take target
+                                               (string-index target #\-))
                              ("armhf"
                               `(link "arm-unknown-linux-gnueabi" "linux-gnu"))
                              ("mips64el"