summary refs log tree commit diff
path: root/gnu/packages/gnupg.scm
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2022-09-16 19:21:01 +0200
committerMarius Bakke <marius@gnu.org>2022-09-16 22:41:21 +0200
commit887e83997e4c3fdab20cd3d2aec6ae3e66850669 (patch)
tree295048f4a3217fe3815aa83e869498af5e984024 /gnu/packages/gnupg.scm
parent7e0f2728a46b8f96b875a7199655bd63ad6a9fff (diff)
downloadguix-887e83997e4c3fdab20cd3d2aec6ae3e66850669.tar.gz
gnu: libgcrypt: Provide absolute gpgrt-config also for native builds.
This fixes a regression since 497080c10ef154818795dd544fe4d606b1e8535d that
would cause things like LIBGCRYPT-STATIC from (gnu packages cryptsetup) to
refer to the wrong libgpg-error.

* gnu/packages/gnupg.scm (libgcrypt)[arguments]: Add "ac_cv_path_GPGRT_CONFIG"
to #:configure-flags, and remove the cross-compile stanza.
Diffstat (limited to 'gnu/packages/gnupg.scm')
-rw-r--r--gnu/packages/gnupg.scm20
1 files changed, 10 insertions, 10 deletions
diff --git a/gnu/packages/gnupg.scm b/gnu/packages/gnupg.scm
index e81c89f719..bd8a7876bc 100644
--- a/gnu/packages/gnupg.scm
+++ b/gnu/packages/gnupg.scm
@@ -178,18 +178,18 @@ Daemon and possibly more in the future.")
      `(#:configure-flags
        (list (string-append "--with-libgpg-error-prefix="
                             (assoc-ref %build-inputs "libgpg-error-host"))
+             ;; libgcrypt is transitioning from gpg-error-config to
+             ;; gpgrt-config, and in the process the
+             ;; --with-libgpg-error-config prefix defined above is
+             ;; not respected.  See <https://dev.gnupg.org/T5365>.
+             ;; TODO: transition to pkg-config instead of these scripts.
+             (string-append "ac_cv_path_GPGRT_CONFIG="
+                            (assoc-ref %build-inputs
+                                       "libgpg-error-host")
+                            "/bin/gpgrt-config")
              ,@(if (%current-target-system)
                    ;; When cross-compiling, _gcry_mpih_lshift etc are undefined.
-                   `("--disable-asm"
-                     ;; libgcrypt is transitioning from gpg-error-config to
-                     ;; gpgrt-config, and in the process the
-                     ;; --with-libgpg-error-config prefix defined above is
-                     ;; not respected.  See <https://dev.gnupg.org/T5365>.
-                     ;; TODO: transition to pkg-config instead of these scripts.
-                     (string-append "ac_cv_path_GPGRT_CONFIG="
-                                    (assoc-ref %build-inputs
-                                               "libgpg-error-host")
-                                    "/bin/gpgrt-config"))
+                   `("--disable-asm")
                    '()))))
     (outputs '("out" "debug"))
     (home-page "https://gnupg.org/")