summary refs log tree commit diff
path: root/gnu/packages/gnupg.scm
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2017-06-07 12:11:24 -0400
committerLeo Famulari <leo@famulari.name>2017-06-07 12:11:55 -0400
commitc67d587f94173fd42d65097165afc5c512935646 (patch)
treeee2bac9d683d0dec98d611d5e590b06d9876cad3 /gnu/packages/gnupg.scm
parent4f493cba06b97de756123b3855ea52dcf1ad3555 (diff)
parent4679dd6967c21e21c740cd88e17191b8e2aac5ee (diff)
downloadguix-c67d587f94173fd42d65097165afc5c512935646.tar.gz
Merge branch 'master' into core-updates
This merge commit includes a fix for CVE-2017-6512 in Perl 5.26.0.
Diffstat (limited to 'gnu/packages/gnupg.scm')
-rw-r--r--gnu/packages/gnupg.scm29
1 files changed, 29 insertions, 0 deletions
diff --git a/gnu/packages/gnupg.scm b/gnu/packages/gnupg.scm
index 5c04745ff5..d4d52ee6d0 100644
--- a/gnu/packages/gnupg.scm
+++ b/gnu/packages/gnupg.scm
@@ -407,6 +407,35 @@ instead.  This way bug fixes or improvements can be done at a central place
 and every application benefits from this.")
     (license license:lgpl2.1+)))
 
+(define-public qgpgme
+  (package
+    (inherit gpgme)
+    (name "qgpgme")
+    (arguments
+     `(#:phases
+       (modify-phases %standard-phases
+         (add-before 'build 'chdir-and-symlink
+           (lambda* (#:key inputs #:allow-other-keys)
+             (let ((gpgme (assoc-ref inputs "gpgme")))
+               (symlink (string-append gpgme "/lib/libgpgmepp.la")
+                        "lang/cpp/src/libgpgmepp.la")
+               (symlink (string-append gpgme "/lib/libgpgme.la")
+                        "src/libgpgme.la"))
+             (chdir "lang/qt")
+             #t)))))
+    (native-inputs
+     `(("pkg-config" ,pkg-config)))
+    (inputs
+     `(("gpgme" ,gpgme)
+       ("qtbase" ,qtbase)
+       ,@(package-inputs gpgme)))
+    (synopsis "Qt API bindings for gpgme")
+    (description "QGpgme provides a very high level Qt API around GpgMEpp.
+
+QGpgME was originally developed as part of libkleo and incorporated into
+gpgpme starting with version 1.7.")
+    (license license:gpl2+))) ;; Note: this differs from gpgme
+
 (define-public python-gpg
   (package
     (name "python-gpg")