summary refs log tree commit diff
path: root/gnu/packages/gnupg.scm
diff options
context:
space:
mode:
authorAndreas Enge <andreas@enge.fr>2015-02-19 21:22:25 +0100
committerAndreas Enge <andreas@enge.fr>2015-02-19 21:22:25 +0100
commitc18ea90fd9812c1dd7cebba3dd519e631e0d9fee (patch)
tree67ce4740b44d4c3f6ab6600d31a96da2e2dd9e6b /gnu/packages/gnupg.scm
parentfdb316266548d5a158457b5d2652697f12ebf7ff (diff)
downloadguix-c18ea90fd9812c1dd7cebba3dd519e631e0d9fee.tar.gz
gnu: Add npth.
* gnu/packages/gnupg.scm (npth): New variable.
Diffstat (limited to 'gnu/packages/gnupg.scm')
-rw-r--r--gnu/packages/gnupg.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/gnupg.scm b/gnu/packages/gnupg.scm
index fa44d1f438..a7b303bcaa 100644
--- a/gnu/packages/gnupg.scm
+++ b/gnu/packages/gnupg.scm
@@ -162,6 +162,31 @@ as well as the CMS easily accessible by other applications.  Both
 specifications are building blocks of S/MIME and TLS.")
     (license gpl3+)))
 
+(define-public npth
+  (package
+    (name "npth")
+    (version "1.1")
+    (source
+     (origin
+      (method url-fetch)
+      (uri (string-append
+            "mirror://gnupg/npth/npth-"
+            version ".tar.bz2"))
+      (sha256
+       (base32
+        "0zyzwmk4mp6pas87jz35zx0jvwdz7x5b13w225gs73gcn8g5cv49"))))
+    (build-system gnu-build-system)
+    (home-page "http://www.gnupg.org")
+    (synopsis "Non-preemptive thread library")
+    (description
+     "Npth is a library to provide the GNU Pth API and thus a non-preemptive
+threads implementation.
+
+In contrast to GNU Pth is is based on the system's standard threads
+implementation.  This allows the use of libraries which are not
+compatible to GNU Pth.")
+    (license (list lgpl3+ gpl2+)))) ; dual license
+
 (define-public gnupg
   (package
     (name "gnupg")