summary refs log tree commit diff
path: root/gnu/packages/gnupg.scm
diff options
context:
space:
mode:
authorChristopher Baines <mail@cbaines.net>2016-10-09 21:27:11 +0100
committerLudovic Courtès <ludo@gnu.org>2016-10-10 00:06:15 +0200
commit41edb23f5e13472309b5fdc0eb0e5730ec90e9ab (patch)
tree068fddb8e824af950374a5b446c7541f0d34811f /gnu/packages/gnupg.scm
parent9614897b71e133a65433ad11de5581a89ffa6118 (diff)
downloadguix-41edb23f5e13472309b5fdc0eb0e5730ec90e9ab.tar.gz
gnu: Add pinentry-gnome3.
* gnu/packages/gnupg.scm (pinentry-gnome3): New variable.

Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/gnupg.scm')
-rw-r--r--gnu/packages/gnupg.scm17
1 files changed, 17 insertions, 0 deletions
diff --git a/gnu/packages/gnupg.scm b/gnu/packages/gnupg.scm
index b4b4f75be1..5fcc03a222 100644
--- a/gnu/packages/gnupg.scm
+++ b/gnu/packages/gnupg.scm
@@ -8,6 +8,7 @@
 ;;; Copyright © 2015, 2016 Ricardo Wurmus <rekado@elephly.net>
 ;;; Copyright © 2016 Christopher Allan Webber <cwebber@dustycloud.org>
 ;;; Copyright © 2016 Nils Gillmann <ng0@libertad.pw>
+;;; Copyright © 2016 Christopher Baines <mail@cbaines.net>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -637,6 +638,22 @@ including tools for signing keys, keyring analysis, and party preparation.
      "Pinentry provides a console and a GTK+ GUI that allows users to enter a
 passphrase when @code{gpg} is run and needs it.")))
 
+(define-public pinentry-gnome3
+  (package
+    (inherit pinentry-tty)
+    (name "pinentry-gnome3")
+    (inputs
+     `(("gtk+" ,gtk+-2)
+       ("gcr" ,gcr)
+       ("glib" ,glib)
+       ,@(package-inputs pinentry-tty)))
+    (arguments
+     `(#:configure-flags '("--enable-pinentry-gnome3")))
+    (description
+     "Pinentry provides a console and a GUI designed for use with GNOME@tie{}3
+that allows users to enter a passphrase when required by @code{gpg} or other
+software.")))
+
 (define-public pinentry-qt
   (package
     (inherit pinentry-tty)