summary refs log tree commit diff
path: root/gnu/packages/gnupg.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2016-07-20 11:42:02 +0200
committerLudovic Courtès <ludo@gnu.org>2016-07-20 11:42:17 +0200
commit7575655212ecfbcd1f04e429c8a7a41f8720d027 (patch)
tree558982d3cf50ef6b19ef293850de1f485fde66a6 /gnu/packages/gnupg.scm
parent5d4c90ae02f1e0b42d575bba2d828d63aaf79be5 (diff)
parent5f01078129f4eaa4760a14f22761cf357afb6738 (diff)
downloadguix-7575655212ecfbcd1f04e429c8a7a41f8720d027.tar.gz
Merge branch 'master' into core-updates
Diffstat (limited to 'gnu/packages/gnupg.scm')
-rw-r--r--gnu/packages/gnupg.scm24
1 files changed, 12 insertions, 12 deletions
diff --git a/gnu/packages/gnupg.scm b/gnu/packages/gnupg.scm
index 2ef241036a..2b4ce71866 100644
--- a/gnu/packages/gnupg.scm
+++ b/gnu/packages/gnupg.scm
@@ -60,7 +60,7 @@
        (base32
         "0ywxwswizmkyciy480kzczxn6nhbgzf3z8my4nk43nvv67k4x87j"))))
     (build-system gnu-build-system)
-    (home-page "http://gnupg.org")
+    (home-page "https://gnupg.org")
     (synopsis "Library of error values for GnuPG components")
     (description
      "Libgpg-error is a small library that defines common error values
@@ -96,7 +96,7 @@ Daemon and possibly more in the future.")
        (list (string-append "--with-gpg-error-prefix="
                             (assoc-ref %build-inputs "libgpg-error-host")))))
     (outputs '("out" "debug"))
-    (home-page "http://gnupg.org/")
+    (home-page "https://gnupg.org/")
     (synopsis "Cryptographic function library")
     (description
      "Libgcrypt is a general-purpose cryptographic library.  It provides the
@@ -122,7 +122,7 @@ generation.")
 (define-public libassuan
   (package
     (name "libassuan")
-    (version "2.4.2")
+    (version "2.4.3")
     (source
      (origin
       (method url-fetch)
@@ -130,11 +130,11 @@ generation.")
                           version ".tar.bz2"))
       (sha256
        (base32
-        "086bbcdnvs48qq5g4iac7dpk76j0q3jrp16mchdvyx0b720xq1mv"))))
+        "0w9bmasln4z8mn16s1is55a06w3nv8jbyal496z5jvr5vcxkm112"))))
     (build-system gnu-build-system)
     (propagated-inputs
      `(("libgpg-error" ,libgpg-error) ("pth" ,pth)))
-    (home-page "http://gnupg.org")
+    (home-page "https://gnupg.org")
     (synopsis
      "IPC library used by GnuPG and related software")
     (description
@@ -171,7 +171,7 @@ provided.")
                    '())
              (string-append "--with-gpg-error-prefix="
                             (assoc-ref %build-inputs "libgpg-error")))))
-    (home-page "http://www.gnupg.org")
+    (home-page "https://www.gnupg.org")
     (synopsis "CMS and X.509 access library")
     (description
      "KSBA (pronounced Kasbah) is a library to make X.509 certificates
@@ -195,7 +195,7 @@ specifications are building blocks of S/MIME and TLS.")
        (base32
         "12n0nvhw4fzwp0k7gjv3rc6pdml0qiinbbfiz4ilg6pl5kdxvnvd"))))
     (build-system gnu-build-system)
-    (home-page "http://www.gnupg.org")
+    (home-page "https://www.gnupg.org")
     (synopsis "Non-preemptive thread library")
     (description
      "Npth is a library to provide the GNU Pth API and thus a non-preemptive
@@ -242,7 +242,7 @@ compatible to GNU Pth.")
           (substitute* "tests/openpgp/defs.inc"
             (("/bin/pwd") (which "pwd"))))
        %standard-phases)))
-    (home-page "http://gnupg.org/")
+    (home-page "https://gnupg.org/")
     (synopsis "GNU Privacy Guard")
     (description
      "The GNU Privacy Guard is a complete implementation of the OpenPGP
@@ -332,7 +332,7 @@ libskba (working with X.509 certificates and CMS data).")
      `(("gnupg" ,gnupg-2.0)
        ("libassuan" ,libassuan)))
     (arguments '(#:make-flags '("GPG=gpg2")))
-    (home-page "http://www.gnupg.org/related_software/gpgme/")
+    (home-page "https://www.gnupg.org/related_software/gpgme/")
     (synopsis "Library providing simplified access to GnuPG functionality")
     (description
      "GnuPG Made Easy (GPGME) is a library designed to make access to GnuPG
@@ -418,7 +418,7 @@ decrypt messages using the OpenPGP format by making use of GPGME.")
                                     "test_gnupg.py" "--no-doctests")))))))
     (native-inputs
      `(("gnupg" ,gnupg-1)))
-    (home-page "http://packages.python.org/python-gnupg/index.html")
+    (home-page "https://packages.python.org/python-gnupg/index.html")
     (synopsis "Wrapper for the GNU Privacy Guard")
     (description
       "This module allows easy access to GnuPG’s key management, encryption
@@ -466,7 +466,7 @@ to the process.
 pius-keyring-mgr and pius-party-worksheet help organisers of
 PGP keysigning parties.")
    (license license:gpl2)
-   (home-page "http://www.phildev.net/pius/index.shtml")))
+   (home-page "https://www.phildev.net/pius/index.shtml")))
 
 (define-public signing-party
   (package
@@ -566,7 +566,7 @@ including tools for signing keys, keyring analysis, and party preparation.
    ;; and caff and gpgsigs: bsd-3, see
    ;; http://packages.debian.org/changelogs/pool/main/s/signing-party/current/copyright
    (license license:gpl2)
-   (home-page "http://pgp-tools.alioth.debian.org/")))
+   (home-page "https://pgp-tools.alioth.debian.org/")))
 
 (define-public pinentry-tty
   (package