summary refs log tree commit diff
path: root/gnu/packages/gnupg.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2016-07-24 18:49:28 +0200
committerLudovic Courtès <ludo@gnu.org>2016-07-24 19:54:15 +0200
commit6b547d22952fb30c4419d4f81545353907ab398d (patch)
tree4c9d507cf4e063ed08025d228293718d4ec2b098 /gnu/packages/gnupg.scm
parent20e29643449adbb9658c0d3bec9c8b117697fe41 (diff)
downloadguix-6b547d22952fb30c4419d4f81545353907ab398d.tar.gz
doc: gnupg@2.0: Use 'modify-phases'.
* gnu/packages/gnupg.scm (gnupg-2.0)[arguments]: Use 'modify-phases'.
Diffstat (limited to 'gnu/packages/gnupg.scm')
-rw-r--r--gnu/packages/gnupg.scm11
1 files changed, 5 insertions, 6 deletions
diff --git a/gnu/packages/gnupg.scm b/gnu/packages/gnupg.scm
index f26574cf73..2391632b4c 100644
--- a/gnu/packages/gnupg.scm
+++ b/gnu/packages/gnupg.scm
@@ -279,12 +279,11 @@ libskba (working with X.509 certificates and CMS data).")
        ("readline" ,readline)))
    (arguments
     `(#:phases
-       (alist-cons-before
-        'configure 'patch-config-files
-        (lambda _
-          (substitute* "tests/openpgp/Makefile.in"
-            (("/bin/sh") (which "bash"))))
-       %standard-phases)))))
+      (modify-phases %standard-phase
+        (add-before 'configure 'patch-config-files
+          (lambda _
+            (substitute* "tests/openpgp/Makefile.in"
+              (("/bin/sh") (which "bash"))))))))))
 
 (define-public gnupg-1
   (package (inherit gnupg)