summary refs log tree commit diff
path: root/gnu/packages/gnuzilla.scm
diff options
context:
space:
mode:
authorBrian Cully <bjc@spork.org>2023-01-03 18:48:39 -0500
committerRicardo Wurmus <rekado@elephly.net>2023-01-04 12:40:17 +0100
commit201793fd07f602270b2375491a2f5d1d85d4f2b1 (patch)
treef3891e77b8dc6e1af1bf45a1646a44de629c46e7 /gnu/packages/gnuzilla.scm
parentd62c65d5ad49d3bf7ae24b31743d96241170faca (diff)
downloadguix-201793fd07f602270b2375491a2f5d1d85d4f2b1.tar.gz
gnu: hunspell: Move hunspell and dictionaries to hunspell module.
Consolidate hunspell and its dictionaries into the (gnu packages hunspell)
module instead of having them scattered about.

* gnu/packages/aspell.scm (aspell-word-list, define-word-list-dictionary,
hunspell-dict-{en, en-au, en-gb, en-gb-ize, en-us}): Remove variables.
* gnu/packages/libreoffice.scm (hunspell, dicollecte-french-dictionary,
define-french-dictionary, hunspell-dict-fr-{classique, moderne, réforme,
toutes-variantes}, hunspell-dict-pl, hunspell-dict-de, hunspell-dict-hu):
Remove variables.
* gnu/packages/hunspell.scm (hunspell, dicollecte-french-dictionary,
define-french-dictionary, hunspell-dict-fr-{classique, moderne, réforme,
toutes-variantes}, hunspell-dict-pl, hunspell-dict-de, hunspell-dict-hu,
aspell-word-list, define-word-list-dictionary, hunspell-dict-{en, en-au,
en-gb, en-gb-ize, en-us}): Add variables.
(hunspell-dictionary): Explicitly declare upstream libreoffice version to
prevent circular dependency.
* gnu/packages/ebook.scm,
gnu/packages/enchant.scm,
gnu/packages/freedesktop.scm,
gnu/packages/gnuzilla.scm,
gnu/packages/kde-frameworks.scm,
gnu/packages/messaging.scm,
gnu/packages/scribus.scm,
gnu/packages/task-management.scm,
gnu/packages/telegram.scm,
gnu/packages/tex.scm,
gnu/packages/text-editors.scm,
gnu/packages/video.scm: Adjust module imports.
Diffstat (limited to 'gnu/packages/gnuzilla.scm')
-rw-r--r--gnu/packages/gnuzilla.scm2
1 files changed, 1 insertions, 1 deletions
diff --git a/gnu/packages/gnuzilla.scm b/gnu/packages/gnuzilla.scm
index b507ec0406..01b6245f8b 100644
--- a/gnu/packages/gnuzilla.scm
+++ b/gnu/packages/gnuzilla.scm
@@ -70,8 +70,8 @@
   #:use-module (gnu packages compression)
   #:use-module (gnu packages fontutils)
   #:use-module (gnu packages fonts)
+  #:use-module (gnu packages hunspell)
   #:use-module (gnu packages libevent)
-  #:use-module (gnu packages libreoffice)  ;for hunspell
   #:use-module (gnu packages image)
   #:use-module (gnu packages libffi)
   #:use-module (gnu packages pulseaudio)