summary refs log tree commit diff
path: root/gnu/packages/gnuzilla.scm
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2016-11-16 22:34:11 -0500
committerMark H Weaver <mhw@netris.org>2016-11-16 22:34:11 -0500
commit2f63e087fe60790bc198bea7cb2462cba071437f (patch)
tree5bf2039c8d7b37e7189f57d00e2976a2e4385bff /gnu/packages/gnuzilla.scm
parentfe047e1380e4b609a684a7cdbab3c625ca1a43d8 (diff)
downloadguix-2f63e087fe60790bc198bea7cb2462cba071437f.tar.gz
Revert "gnu: icecat: Enable gtk3 support."
This reverts commit eaf72e218e38c0c908ee30c914ab7d9c0c0389b8.

IceCat misbehaves with gtk+3, most notably the scroll bar handles are
invisible.  Here we revert back to gtk+2 until these problems can be
addressed.
Diffstat (limited to 'gnu/packages/gnuzilla.scm')
-rw-r--r--gnu/packages/gnuzilla.scm5
1 files changed, 2 insertions, 3 deletions
diff --git a/gnu/packages/gnuzilla.scm b/gnu/packages/gnuzilla.scm
index 2b4db03bfe..3b00d3c717 100644
--- a/gnu/packages/gnuzilla.scm
+++ b/gnu/packages/gnuzilla.scm
@@ -426,8 +426,7 @@ standards.")
        ("glib" ,glib)
        ("gstreamer" ,gstreamer)
        ("gst-plugins-base" ,gst-plugins-base)
-       ("gtk+" ,gtk+)
-       ("gtk+-2" ,gtk+-2)
+       ("gtk+" ,gtk+-2)
        ("pango" ,pango)
        ("freetype" ,freetype)
        ("hunspell" ,hunspell)
@@ -471,7 +470,7 @@ standards.")
        ;; practice somehow.  See <http://hydra.gnu.org/build/378133>.
        #:validate-runpath? #f
 
-       #:configure-flags '("--enable-default-toolkit=cairo-gtk3"
+       #:configure-flags '("--enable-default-toolkit=cairo-gtk2"
                            "--enable-pango"
                            "--enable-gio"
                            "--enable-svg"