summary refs log tree commit diff
path: root/gnu/packages/gnuzilla.scm
diff options
context:
space:
mode:
authorJonathan Brielmaier <jonathan.brielmaier@web.de>2022-06-01 11:06:27 +0200
committerJonathan Brielmaier <jonathan.brielmaier@web.de>2022-06-01 15:12:39 +0200
commita8228a62535da9bc68125242e237b23b6a4af366 (patch)
treeb62d2b97ec7abf4131bdb1749b8de8133f25995a /gnu/packages/gnuzilla.scm
parent91861046f2bddb37ece693810bcccb80ec2ed4ce (diff)
downloadguix-a8228a62535da9bc68125242e237b23b6a4af366.tar.gz
gnu: icedove: Update to 91.10.0 [fixes CVE-2022-1834].
* gnu/packages/gnuzilla.scm (icedove): Update to 91.10.0.
Diffstat (limited to 'gnu/packages/gnuzilla.scm')
-rw-r--r--gnu/packages/gnuzilla.scm8
1 files changed, 4 insertions, 4 deletions
diff --git a/gnu/packages/gnuzilla.scm b/gnu/packages/gnuzilla.scm
index 41dd32955d..aa2099016e 100644
--- a/gnu/packages/gnuzilla.scm
+++ b/gnu/packages/gnuzilla.scm
@@ -977,11 +977,11 @@ standards of the IceCat project.")
        (cpe-version . ,(first (string-split version #\-)))))))
 
 ;; Update this together with icecat!
-(define %icedove-build-id "20220503000000") ;must be of the form YYYYMMDDhhmmss
+(define %icedove-build-id "20220531000000") ;must be of the form YYYYMMDDhhmmss
 (define-public icedove
   (package
     (name "icedove")
-    (version "91.9.0")
+    (version "91.10.0")
     (source icecat-source)
     (properties
      `((cpe-name . "thunderbird_esr")))
@@ -1260,7 +1260,7 @@ standards of the IceCat project.")
         ;; in the Thunderbird release tarball.  We don't use the release
         ;; tarball because it duplicates the Icecat sources and only adds the
         ;; "comm" directory, which is provided by this repository.
-        ,(let ((changeset "8b44d29de6525d6379f163f50c1a900d4540ef1b"))
+        ,(let ((changeset "4a4b901410a9055d078d0cdd7c62b2b5d56ffbad"))
            (origin
              (method hg-fetch)
              (uri (hg-reference
@@ -1269,7 +1269,7 @@ standards of the IceCat project.")
              (file-name (string-append "thunderbird-" version "-checkout"))
              (sha256
               (base32
-               "1k7zy53il3i4k2k7mc33j0wsgpjrsghmmj6afs14hk9j95byvayy")))))
+               "0i2wpi08jfksqqc0j6q362nyk3zmlqd5ds2w7mm74infvrw6fzzq")))))
        ("cargo" ,rust "cargo")
        ("clang" ,clang-11)
        ("llvm" ,llvm-11)