summary refs log tree commit diff
path: root/gnu/packages/gnuzilla.scm
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2015-01-30 02:37:44 -0500
committerMark H Weaver <mhw@netris.org>2015-01-30 10:54:41 -0500
commit582100a0c07a245abd1580e9caaf9896e0d0e67f (patch)
treeb9291dec4d035f299461baa75c4852a25365c533 /gnu/packages/gnuzilla.scm
parent686e025d79e9747adb96c1d328c799539a2ec8c3 (diff)
downloadguix-582100a0c07a245abd1580e9caaf9896e0d0e67f.tar.gz
gnu: icecat: Update to 31.4.0.
* gnu/packages/patches/icecat-CVE-2014-1587-bug-1042567.patch,
  gnu/packages/patches/icecat-CVE-2014-1587-bug-1072847.patch,
  gnu/packages/patches/icecat-CVE-2014-1587-bug-1079729.patch,
  gnu/packages/patches/icecat-CVE-2014-1587-bug-1080312.patch,
  gnu/packages/patches/icecat-CVE-2014-1587-bug-1089207.patch,
  gnu/packages/patches/icecat-CVE-2014-1590.patch,
  gnu/packages/patches/icecat-CVE-2014-1592.patch,
  gnu/packages/patches/icecat-CVE-2014-1593.patch,
  gnu/packages/patches/icecat-CVE-2014-1594.patch,
  gnu/packages/patches/icecat-CVE-2014-8634-pt1.patch,
  gnu/packages/patches/icecat-CVE-2014-8634-pt2.patch,
  gnu/packages/patches/icecat-CVE-2014-8638-pt1.patch,
  gnu/packages/patches/icecat-CVE-2014-8638-pt2.patch,
  gnu/packages/patches/icecat-CVE-2014-8639.patch,
  gnu/packages/patches/icecat-CVE-2014-8641.patch,
  gnu/packages/patches/icecat-armhf-xpcom.patch: Remove files.
* gnu-system.am (dist_patch_DATA): Remove them.
* gnu/packages/gnuzilla.scm: Update to 31.4.0.  Remove patches.
Diffstat (limited to 'gnu/packages/gnuzilla.scm')
-rw-r--r--gnu/packages/gnuzilla.scm23
1 files changed, 3 insertions, 20 deletions
diff --git a/gnu/packages/gnuzilla.scm b/gnu/packages/gnuzilla.scm
index 9c6b39f3d2..862dfe1a31 100644
--- a/gnu/packages/gnuzilla.scm
+++ b/gnu/packages/gnuzilla.scm
@@ -213,32 +213,15 @@ standards.")
 (define-public icecat
   (package
     (name "icecat")
-    (version "31.2.0")
+    (version "31.4.0")
     (source
      (origin
       (method url-fetch)
       (uri (string-append "mirror://gnu/gnuzilla/"
-                          version "/" name "-" version ".tar.xz"))
+                          version "/" name "-" version ".tar.bz2"))
       (sha256
        (base32
-        "02r9klfc0z26w270inq652249hq0wfzvwhzvwmk0n8v8nzkk5idh"))
-      (patches (map search-patch
-                    '("icecat-CVE-2014-1587-bug-1042567.patch"
-                      "icecat-CVE-2014-1587-bug-1072847.patch"
-                      "icecat-CVE-2014-1587-bug-1079729.patch"
-                      "icecat-CVE-2014-1587-bug-1080312.patch"
-                      "icecat-CVE-2014-1587-bug-1089207.patch"
-                      "icecat-CVE-2014-1590.patch"
-                      "icecat-CVE-2014-1592.patch"
-                      "icecat-CVE-2014-1593.patch"
-                      "icecat-CVE-2014-1594.patch"
-                      "icecat-armhf-xpcom.patch"
-                      "icecat-CVE-2014-8639.patch"
-                      "icecat-CVE-2014-8634-pt1.patch"
-                      "icecat-CVE-2014-8634-pt2.patch"
-                      "icecat-CVE-2014-8641.patch"
-                      "icecat-CVE-2014-8638-pt1.patch"
-                      "icecat-CVE-2014-8638-pt2.patch")))))
+        "0q5ilgfybcrbwf9hq9zc1cpnlhq1pddnnjmdrxrcrrg8lgx5kkc2"))))
     (build-system gnu-build-system)
     (inputs
      `(("alsa-lib" ,alsa-lib)