summary refs log tree commit diff
path: root/gnu/packages/gnuzilla.scm
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2019-06-04 04:10:04 -0400
committerMark H Weaver <mhw@netris.org>2019-06-04 04:21:52 -0400
commit05947d92b65dd13a8b593e1bdde3dd76b11211c2 (patch)
tree396bc5f202b3eb08ed050d991d7c70a3c5614e2f /gnu/packages/gnuzilla.scm
parent92b1b6f6afaf722889a03d17d0256cf5248db73f (diff)
downloadguix-05947d92b65dd13a8b593e1bdde3dd76b11211c2.tar.gz
gnu: icecat: Update to 60.7.0-guix2.
This includes updates to bundled extensions from the upstream
GNU IceCat 60.7.0-gnu1 release.

* gnu/packages/gnuzilla.scm (%icecat-version): Update to 60.7.0-guix2.
(icecat-source)[upstream-icecat-base-version]: Update to 60.7.0.
[upstream-icecat-source, gnuzilla-source]: Update hashes.
[origin]: Remove the substitutions that dealt with debian-specific package
code in the makeicecat script, since that code has been removed upstream.
(icecat)[arguments]: Adapt the 'install-desktop-entry' phase to avoid using
the Debian desktop file, which is no longer included in the IceCat sources.
* gnu/packages/patches/icecat-makeicecat.patch: Adapt to upstream changes.
Diffstat (limited to 'gnu/packages/gnuzilla.scm')
-rw-r--r--gnu/packages/gnuzilla.scm67
1 files changed, 17 insertions, 50 deletions
diff --git a/gnu/packages/gnuzilla.scm b/gnu/packages/gnuzilla.scm
index 825678bfc6..c2356f2a44 100644
--- a/gnu/packages/gnuzilla.scm
+++ b/gnu/packages/gnuzilla.scm
@@ -426,7 +426,7 @@ from forcing GEXP-PROMISE."
                       #:system system
                       #:guile-for-build guile)))
 
-(define %icecat-version "60.7.0-guix1")
+(define %icecat-version "60.7.0-guix2")
 
 ;; 'icecat-source' is a "computed" origin that generates an IceCat tarball
 ;; from the corresponding upstream Firefox ESR tarball, using the 'makeicecat'
@@ -450,7 +450,7 @@ from forcing GEXP-PROMISE."
              (base32
               "08x0nijh0ja5jza95a8y030ibk756bn7zlw3a3c4750yilfhqpqa"))))
 
-         (upstream-icecat-base-version "60.3.0") ; maybe older than base-version
+         (upstream-icecat-base-version "60.7.0") ; maybe older than base-version
          (upstream-icecat-gnu-version "1")
          (upstream-icecat-version (string-append upstream-icecat-base-version
                                                  "-gnu"
@@ -463,7 +463,7 @@ from forcing GEXP-PROMISE."
                   "/icecat-" upstream-icecat-version ".tar.bz2"))
             (sha256
              (base32
-              "0icnl64nxcyf7dprpdpygxhabsvyhps8c3ixysj9bcdlj9q34ib1"))))
+              "09xqdfd8rwbn2n6m7n059qf1psbrj5v5kfzm7gg5xng22ddxawv8"))))
 
          (gnuzilla-commit (string-append "v" upstream-icecat-base-version))
          (gnuzilla-source
@@ -475,7 +475,7 @@ from forcing GEXP-PROMISE."
             (file-name (git-file-name "gnuzilla" upstream-icecat-base-version))
             (sha256
              (base32
-              "19wal7hkbb4wvk40hs6d7a5paal2bfday08hwssm02srcbv48fj0"))))
+              "1vqhb0py28hnwcynbaad304ziciz1kn5bv1qg2q4f7g13js3b1hf"))))
 
          (makeicecat-patch
           (local-file (search-patch "icecat-makeicecat.patch"))))
@@ -545,10 +545,6 @@ from forcing GEXP-PROMISE."
                                     #$upstream-icecat-gnu-version "\n"))
                     (("^DATA=.*")
                      "DATA=/tmp/gnuzilla/data\n")
-                    (("^sed .* debian/" all)
-                     (string-append "echo warning: skipped: " all))
-                    (("^debian/rules " all)
-                     (string-append "echo warning: skipped: " all))
                     (("^find extensions/gnu/ ")
                      "find extensions/gnu/ | sort ")
                     (("/bin/sed")
@@ -560,21 +556,19 @@ from forcing GEXP-PROMISE."
                 (rename-file firefox-dir icecat-dir)
 
                 (with-directory-excursion icecat-dir
-                  (for-each mkdir-p '("l10n" "debian/config"))
-                  (call-with-output-file "debian/control" (const #t))
+                  (mkdir "l10n")
                   (format #t "Running makeicecat script...~%")
                   (force-output)
                   (invoke "bash" "/tmp/gnuzilla/makeicecat")
-                  (for-each delete-file-recursively '("l10n" "debian")))
+                  (delete-file-recursively "l10n"))
 
-                (format #t (string-append "Unpacking l10n/* and debian/* from"
+                (format #t (string-append "Unpacking l10n/* from"
                                           " upstream IceCat tarball...~%"))
                 (force-output)
                 (unless (string=? icecat-dir old-icecat-dir)
                   (symlink icecat-dir old-icecat-dir))
                 (invoke "tar" "xf" #+upstream-icecat-source
-                        (string-append old-icecat-dir "/l10n")
-                        (string-append old-icecat-dir "/debian"))
+                        (string-append old-icecat-dir "/l10n"))
 
                 (format #t "Packing new IceCat tarball...~%")
                 (force-output)
@@ -899,43 +893,16 @@ from forcing GEXP-PROMISE."
          (add-before 'configure 'install-desktop-entry
            (lambda* (#:key outputs #:allow-other-keys)
              ;; Install the '.desktop' file.
-             (define (swallow-%%-directives input output)
-               ;; Interpret '%%ifdef' directives found in the '.desktop' file.
-               (let loop ((state 'top))
-                 (match (read-line input 'concat)
-                   ((? eof-object?)
-                    #t)
-                   ((? string? line)
-                    (cond ((string-prefix? "%%ifdef" line)
-                           (loop 'ifdef))
-                          ((string-prefix? "%%else" line)
-                           (loop 'else))
-                          ((string-prefix? "%%endif" line)
-                           (loop 'top))
-                          (else
-                           (case state
-                             ((top else)
-                              (display line output)
-                              (loop state))
-                             (else
-                              (loop state)))))))))
-
-             (let* ((out (assoc-ref outputs "out"))
+             (let* ((desktop-file "taskcluster/docker/icecat-snap/icecat.desktop")
+                    (out          (assoc-ref outputs "out"))
                     (applications (string-append out "/share/applications")))
-               (call-with-input-file "debian/icecat.desktop.in"
-                 (lambda (input)
-                   (call-with-output-file "debian/icecat.desktop"
-                     (lambda (output)
-                       (swallow-%%-directives input output)))))
-
-               (substitute* "debian/icecat.desktop"
-                 (("@MOZ_DISPLAY_NAME@")
-                  "GNU IceCat")
-                 (("^Exec=@MOZ_APP_NAME@")
-                  (string-append "Exec=" out "/bin/icecat"))
-                 (("@MOZ_APP_NAME@")
-                  "icecat"))
-               (install-file "debian/icecat.desktop" applications)
+               (substitute* desktop-file
+                 (("^Exec=icecat")     (string-append "Exec=" out "/bin/icecat"))
+                 (("IceCat")           "GNU IceCat")
+                 (("Icon=.*")          "Icon=icecat\n")
+                 (("NewWindow")        "new-window")
+                 (("NewPrivateWindow") "new-private-window"))
+               (install-file desktop-file applications)
                #t)))
          (add-after 'install-desktop-entry 'install-icons
            (lambda* (#:key outputs #:allow-other-keys)