summary refs log tree commit diff
path: root/gnu/packages/gnuzilla.scm
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2015-03-25 08:20:49 -0400
committerMark H Weaver <mhw@netris.org>2015-03-25 08:24:10 -0400
commit4c153a9125fa0913077b06b5ed537958ae4ca163 (patch)
tree15367cb88523e11c50cbdd65c97b0b254e7c525a /gnu/packages/gnuzilla.scm
parent614c2188420a266ec512c9c04af3bb2ea46c4dc4 (diff)
downloadguix-4c153a9125fa0913077b06b5ed537958ae4ca163.tar.gz
gnu: icecat: Apply fixes for CVE-2015-{0817,0818} and other selected bugs.
* gnu/packages/patches/icecat-CVE-2015-0817.patch,
  gnu/packages/patches/icecat-CVE-2015-0818-pt1.patch,
  gnu/packages/patches/icecat-CVE-2015-0818-pt2.patch,
  gnu/packages/patches/icecat-bug-1127780.patch,
  gnu/packages/patches/icecat-bug-1144991.patch,
  gnu/packages/patches/icecat-bug-1145870.patch,
  gnu/packages/patches/icecat-bug-1146339.patch: New files.
* gnu-system.am (dist_patch_DATA): Add them.
* gnu/packages/gnuzilla.scm (icecat): Add patches.
Diffstat (limited to 'gnu/packages/gnuzilla.scm')
-rw-r--r--gnu/packages/gnuzilla.scm9
1 files changed, 8 insertions, 1 deletions
diff --git a/gnu/packages/gnuzilla.scm b/gnu/packages/gnuzilla.scm
index 1d450cda64..1e9deb8bff 100644
--- a/gnu/packages/gnuzilla.scm
+++ b/gnu/packages/gnuzilla.scm
@@ -224,7 +224,14 @@ standards.")
                           version "/" name "-" version ".tar.bz2"))
       (sha256
        (base32
-        "1rr4axghaypdkrf60i1qp6dz4cd29ya02fs3vyffvp4x9kgcq2dd"))))
+        "1rr4axghaypdkrf60i1qp6dz4cd29ya02fs3vyffvp4x9kgcq2dd"))
+      (patches (map search-patch '("icecat-bug-1127780.patch"
+                                   "icecat-CVE-2015-0817.patch"
+                                   "icecat-bug-1144991.patch"
+                                   "icecat-CVE-2015-0818-pt1.patch"
+                                   "icecat-bug-1145870.patch"
+                                   "icecat-CVE-2015-0818-pt2.patch"
+                                   "icecat-bug-1146339.patch")))))
     (build-system gnu-build-system)
     (inputs
      `(("alsa-lib" ,alsa-lib)