summary refs log tree commit diff
path: root/gnu/packages/gnuzilla.scm
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2019-03-19 19:01:48 -0400
committerMark H Weaver <mhw@netris.org>2019-03-19 22:36:37 -0400
commit8cf160e12253d65e9122d56cb602e0907e8c71bc (patch)
treef7f10a542bc6d69d36de34e6b8946111a9e90479 /gnu/packages/gnuzilla.scm
parentd17b1c0891c2e1b2b1bfc92a120e91c1f8909c39 (diff)
downloadguix-8cf160e12253d65e9122d56cb602e0907e8c71bc.tar.gz
gnu: icecat: Improve computed 'icecat-source' tarball.
* gnu/packages/gnuzilla.scm (icecat-source): When packing the new IceCat
tarball, set the mtime of archived files to early 1980.  Remove useless
'string-append' applied to one argument.
Diffstat (limited to 'gnu/packages/gnuzilla.scm')
-rw-r--r--gnu/packages/gnuzilla.scm10
1 files changed, 7 insertions, 3 deletions
diff --git a/gnu/packages/gnuzilla.scm b/gnu/packages/gnuzilla.scm
index 785d5c1342..6992a7b1ca 100644
--- a/gnu/packages/gnuzilla.scm
+++ b/gnu/packages/gnuzilla.scm
@@ -722,11 +722,15 @@ from forcing GEXP-PROMISE."
                         (string-append old-icecat-dir "/l10n")
                         (string-append old-icecat-dir "/debian"))
 
-                (format #t (string-append "Packing new IceCat tarball...~%"))
+                (format #t "Packing new IceCat tarball...~%")
                 (force-output)
                 (invoke "tar" "cfa" #$output
-                        ;; avoid non-determinism in the archive
-                        "--mtime=@0"
+                        ;; Avoid non-determinism in the archive.  We set the
+                        ;; mtime of files in the archive to early 1980 because
+                        ;; the build process fails if the mtime of source
+                        ;; files is pre-1980, due to the creation of zip
+                        ;; archives.
+                        "--mtime=@315619200" ; 1980-01-02 UTC
                         "--owner=root:0"
                         "--group=root:0"
                         "--sort=name"